# CVE-2026-33236: NLTK has a Downloader Path Traversal Vulnerability (AFO) - Arbitrary File Overwrite

> Attackers can exploit path traversal in NLTK downloader to overwrite arbitrary files, potentially leading to code execution.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Mar 2026
- **Updated:** 21 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-33236, ECHO-85d4-7fa8-a8c9, GHSA-469j-vmhf-r6v7, PYSEC-2026-2237, ROOT-APP-PYPI-CVE-2026-33236

## What is CVE-2026-33236?

CVE-2026-33236 is a high-severity path traversal vulnerability in nltk, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NLTK (Natural Language Toolkit) is a suite of open source Python modules, data sets, and tutorials supporting research and development in Natural Language Processing. In versions 3.9.3 and prior, the NLTK downloader does not validate the `subdir` and `id` attributes when processing remote XML index files. Attackers can control a remote XML index server to provide malicious values containing path traversal sequences (such as `../`), which can lead to arbitrary directory creation, arbitrary file creation, and arbitrary file overwrite. Commit 89fe2ec2c6bae6e2e7a46dad65cc34231976ed8a patches the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-33236?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions to 3.9.2 | None |
| `nltk` | PyPI | All versions to 3.9.2 | None |
| `nltk` | PyPI | All versions | 3.9.4 |

Products: Nltk Nltk.

## How do I fix CVE-2026-33236?

Upgrade nltk to 3.9.4 or later.

## Is CVE-2026-33236 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33236 exists.

## Other vulnerabilities in nltk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33236 and fix it if it is affected.

What it is: CVE-2026-33236 is a high-severity path traversal vulnerability in nltk, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33236 exists.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions up to 3.9.2; no fix listed
- nltk (PyPI): affected all versions up to 3.9.2; no fix listed
- nltk (PyPI): affected all versions; fixed in 3.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33236/ (Markdown: https://insights.sbomify.com/CVE-2026-33236/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33236
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33236
- OSV: https://osv.dev/vulnerability/CVE-2026-33236

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33236/
Summaries are generated and may contain mistakes; the official description above is the record.
