CVE-2026-33247 NATS credentials are exposed in monitoring port via command-line argv
Attackers can read static credentials from the monitoring port if they are passed via command-line arguments, exposing sensitive authentication data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33247?
CVE-2026-33247 is a high-severity vulnerability in nats-io nats-server, published on 25 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.15 and 2.12.6, if a nats-server is run with static credentials for all clients provided via argv (the command-line), then those credentials are visible to any user who can see the monitoring port, if that too is enabled. The `/debug/vars` end-point contains an unredacted copy of argv. Versions 2.11.15 and 2.12.6 contain a fix. As a workaround, configure credentials inside a configuration file instead of via argv, and do not enable the monitoring port if using secrets in argv. Best practice remains to not expose the monitoring port to the Internet, or to untrusted network sources.
Which versions are affected by CVE-2026-33247?
7 open source packages ship an affected version, including github.com/nats-io/nats-server/v2, nats and github.com/nats-io/nats-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/nats-io/nats-server/v2 Go | All versions | 2.11.15, 2.12.6 |
github.com/nats-io/nats-server/v2 Go | All versions | 2.11.15 |
github.com/nats-io/nats-server/v2 Go | All versions | 2.11.15 |
github.com/nats-io/nats-server/v2 Go | From 2.12.0-RC.1 | 2.12.6 |
github.com/nats-io/nats-server/v2 Go | From 2.12.0-RC.1 | 2.12.6 |
nats Bitnami | All versions | 2.11.15, 2.12.6 |
1 more packages
github.com/nats-io/nats-server Go | All versions | None |
Products include Linuxfoundation Nats-Server.
How do I fix CVE-2026-33247?
Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.11.15 or 2.12.6.
Is CVE-2026-33247 being exploited?
There is no known exploitation of CVE-2026-33247 in the wild and no public exploit code.
Other vulnerabilities in nats-io nats-server
- CVE-2022-28357 NATS nats-server allows directory traversal via unintended path to a management action
- CVE-2026-58253 NATS Server: Route API Auth Bypass
- CVE-2022-24450 Incorrect Authorization in NATS nats-server
- CVE-2026-33216 NATS has MQTT plaintext password disclosure
- CVE-2026-58207 NATS Server: Remote crash via integer overflow in Connz pagination
Sources
Also known as BIT-nats-2026-33247, CLEANSTART-2026-QU10811, DEBIAN-CVE-2026-33247, ECHO-74a4-f57f-f098, GHSA-x6g4-f6q3-fqvv, GO-2026-4827 and 10 more.