# CVE-2026-33247: NATS credentials are exposed in monitoring port via command-line argv

> Attackers can read static credentials from the monitoring port if they are passed via command-line arguments, exposing sensitive authentication data.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2026
- **Updated:** 9 Sep 2026
- **Also known as:** BIT-nats-2026-33247, CLEANSTART-2026-QU10811, DEBIAN-CVE-2026-33247, ECHO-74a4-f57f-f098, GHSA-x6g4-f6q3-fqvv, GO-2026-4827, JLSEC-2026-1131, MINI-394v-p729-r7q3, MINI-474j-c5m2-r5xw, MINI-568x-7wxh-r7vh, MINI-cxw9-g65f-39rw, MINI-fc77-x523-cpcx, MINI-p5rj-8jcg-2qrw, MINI-qgfr-x8cg-6hmp, ROOT-APP-GOBINARY-CVE-2026-33247, UBUNTU-CVE-2026-33247

## What is CVE-2026-33247?

CVE-2026-33247 is a high-severity vulnerability in nats-io nats-server, published on 25 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.15 and 2.12.6, if a nats-server is run with static credentials for all clients provided via argv (the command-line), then those credentials are visible to any user who can see the monitoring port, if that too is enabled. The `/debug/vars` end-point contains an unredacted copy of argv. Versions 2.11.15 and 2.12.6 contain a fix. As a workaround, configure credentials inside a configuration file instead of via argv, and do not enable the monitoring port if using secrets in argv. Best practice remains to not expose the monitoring port to the Internet, or to untrusted network sources.

Weakness: CWE-214 (Invocation of Process Using Visible Sensitive Information), CWE-215 (Insertion of Sensitive Information Into Debugging Code)

## Which versions are affected by CVE-2026-33247?

7 open source packages ship an affected version, including github.com/nats-io/nats-server/v2, nats and github.com/nats-io/nats-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.15, 2.12.6 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.15 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.15 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.12.0-RC.1 | 2.12.6 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.12.0-RC.1 | 2.12.6 |
| `nats` | Bitnami | All versions | 2.11.15, 2.12.6 |
| `github.com/nats-io/nats-server` | Go | All versions | None |

Products: Linuxfoundation Nats-Server.

## How do I fix CVE-2026-33247?

Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.11.15 or 2.12.6.

## Is CVE-2026-33247 being exploited?

There is no known exploitation of CVE-2026-33247 in the wild and no public exploit code.

## Other vulnerabilities in nats-io nats-server

- [CVE-2022-28357](https://insights.sbomify.com/CVE-2022-28357/): NATS nats-server allows directory traversal via unintended path to a management action (critical 9.8)
- [CVE-2026-58253](https://insights.sbomify.com/CVE-2026-58253/): NATS Server: Route API Auth Bypass (high 8.8)
- [CVE-2022-24450](https://insights.sbomify.com/CVE-2022-24450/): Incorrect Authorization in NATS nats-server (high 8.8)
- [CVE-2026-33216](https://insights.sbomify.com/CVE-2026-33216/): NATS has MQTT plaintext password disclosure (high 8.6)
- [CVE-2026-58207](https://insights.sbomify.com/CVE-2026-58207/): NATS Server: Remote crash via integer overflow in Connz pagination (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33247 and fix it if it is affected.

What it is: CVE-2026-33247 is a high-severity vulnerability in nats-io nats-server, published on 25 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33247 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.15, 2.12.6
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.15
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.15
- github.com/nats-io/nats-server/v2 (Go): affected from 2.12.0-RC.1; fixed in 2.12.6
- github.com/nats-io/nats-server/v2 (Go): affected from 2.12.0-RC.1; fixed in 2.12.6
- nats (Bitnami): affected all versions; fixed in 2.11.15, 2.12.6
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33247/ (Markdown: https://insights.sbomify.com/CVE-2026-33247/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33247
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33247
- OSV: https://osv.dev/vulnerability/CVE-2026-33247

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33247/
Summaries are generated and may contain mistakes; the official description above is the record.
