CVE-2026-33248 NATS has mTLS verify_and_map authentication bypass via incorrect Subject DN matching
Attackers with valid certificates can bypass mTLS authentication in NATS Server if specific Subject DN patterns are used, requiring an upgrade to fix.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33248?
CVE-2026-33248 is a medium-severity authentication bypass vulnerability in nats-io nats-server, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.15 and 2.12.6, when using mTLS for client identity, with `verify_and_map` to derive a NATS identity from the client certificate's Subject DN, certain patterns of RDN would not be correctly enforced, allowing for authentication bypass. This does require a valid certificate from a CA already trusted for client certificates, and `DN` naming patterns which the NATS maintainers consider highly unlikely. So this is an unlikely attack. Nonetheless, administrators who have been very sophisticated in their `DN` construction patterns might conceivably be impacted. Versions 2.11.15 and 2.12.6 contain a fix. As a workaround, developers should review their CA issuing practices.
Which versions are affected by CVE-2026-33248?
9 open source packages ship an affected version, including github.com/nats-io/nats-server/v2, nats and github.com/nats-io/nats-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/nats-io/nats-server/v2 Go | All versions | 2.11.15, 2.12.6 |
github.com/nats-io/nats-server/v2 Go | All versions | 2.11.15 |
github.com/nats-io/nats-server/v2 Go | All versions | 2.11.15 |
github.com/nats-io/nats-server/v2 Go | From 2.12.0-RC.1 | 2.12.6 |
github.com/nats-io/nats-server/v2 Go | From 2.12.0-RC.1 | 2.12.6 |
nats Bitnami | All versions | 2.11.15, 2.12.6 |
3 more packages
github.com/nats-io/nats-server Go | All versions | None |
github.com/nats-io/nats-server Go | All versions | None |
github.com/nats-io/nats-server Go | All versions | None |
Products include Linuxfoundation Nats-Server.
How do I fix CVE-2026-33248?
Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.11.15 or 2.12.6.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-33248 being exploited?
There is no known exploitation of CVE-2026-33248 in the wild and no public exploit code.
Other vulnerabilities in nats-io nats-server
- CVE-2022-28357 NATS nats-server allows directory traversal via unintended path to a management action
- CVE-2026-58253 NATS Server: Route API Auth Bypass
- CVE-2022-24450 Incorrect Authorization in NATS nats-server
- CVE-2026-33216 NATS has MQTT plaintext password disclosure
- CVE-2026-58207 NATS Server: Remote crash via integer overflow in Connz pagination
Sources
Also known as BIT-nats-2026-33248, CLEANSTART-2026-YK24413, DEBIAN-CVE-2026-33248, ECHO-eee5-ed4c-8425, GHSA-3f24-pcvm-5jqc, GO-2026-4828 and 10 more.