# CVE-2026-33249: NATS: Message tracing can be redirected to arbitrary subject

> A valid NATS client can redirect message traces to unauthorized subjects, bypassing publish permissions and potentially exposing trace data.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2026
- **Updated:** 26 Mar 2026
- **Also known as:** BIT-nats-2026-33249, CLEANSTART-2026-QF31649, DEBIAN-CVE-2026-33249, GHSA-8m2x-3m6q-6w8j, GO-2026-4826, MINI-6jvx-c2r8-227h, MINI-79vq-c3p7-p74w, MINI-gxjv-9g6x-68j5, MINI-j2fc-r5mg-mcrh, MINI-j3gc-r4wm-mjpm, MINI-jh7h-wpxh-q45q, MINI-vgrw-44j7-6h8m, ROOT-APP-GOBINARY-CVE-2026-33249, UBUNTU-CVE-2026-33249

## What is CVE-2026-33249?

CVE-2026-33249 is a medium-severity missing authorization vulnerability in nats-io nats-server, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Starting in version 2.11.0 and prior to versions 2.11.15 and 2.12.6, a valid client which uses message tracing headers can indicate that the trace messages can be sent to an arbitrary valid subject, including those to which the client does not have publish permission. The payload is a valid trace message and not chosen by the attacker. Versions 2.11.15 and 2.12.6 contain a fix. No known workarounds are available.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-33249?

7 open source packages ship an affected version, including github.com/nats-io/nats-server/v2, nats and github.com/nats-io/nats-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nats-io/nats-server/v2` | Go | From 2.11.0 | 2.11.15, 2.12.6 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.11.0 | 2.11.15 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.11.0 | 2.11.15 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.12.0-preview.1 | 2.12.6 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.12.0-preview.1 | 2.12.6 |
| `nats` | Bitnami | From 2.11.0 | 2.11.15, 2.12.6 |
| `github.com/nats-io/nats-server` | Go | All versions | None |

Products: Linuxfoundation Nats-Server.

## How do I fix CVE-2026-33249?

Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.11.15 or 2.12.6.

## Is CVE-2026-33249 being exploited?

There is no known exploitation of CVE-2026-33249 in the wild and no public exploit code.

## Other vulnerabilities in nats-io nats-server

- [CVE-2022-28357](https://insights.sbomify.com/CVE-2022-28357/): NATS nats-server allows directory traversal via unintended path to a management action (critical 9.8)
- [CVE-2026-58253](https://insights.sbomify.com/CVE-2026-58253/): NATS Server: Route API Auth Bypass (high 8.8)
- [CVE-2022-24450](https://insights.sbomify.com/CVE-2022-24450/): Incorrect Authorization in NATS nats-server (high 8.8)
- [CVE-2026-33216](https://insights.sbomify.com/CVE-2026-33216/): NATS has MQTT plaintext password disclosure (high 8.6)
- [CVE-2026-58207](https://insights.sbomify.com/CVE-2026-58207/): NATS Server: Remote crash via integer overflow in Connz pagination (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33249 and fix it if it is affected.

What it is: CVE-2026-33249 is a medium-severity missing authorization vulnerability in nats-io nats-server, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33249 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/nats-io/nats-server/v2 (Go): affected from 2.11.0; fixed in 2.11.15, 2.12.6
- github.com/nats-io/nats-server/v2 (Go): affected from 2.11.0; fixed in 2.11.15
- github.com/nats-io/nats-server/v2 (Go): affected from 2.11.0; fixed in 2.11.15
- github.com/nats-io/nats-server/v2 (Go): affected from 2.12.0-preview.1; fixed in 2.12.6
- github.com/nats-io/nats-server/v2 (Go): affected from 2.12.0-preview.1; fixed in 2.12.6
- nats (Bitnami): affected from 2.11.0; fixed in 2.11.15, 2.12.6
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33249/ (Markdown: https://insights.sbomify.com/CVE-2026-33249/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33249
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33249
- OSV: https://osv.dev/vulnerability/CVE-2026-33249

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33249/
Summaries are generated and may contain mistakes; the official description above is the record.
