# CVE-2026-33250: Crash when receiving specially-crafted packets


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-33250, DSA-6173-1, GHSA-f76g-6w3f-f6r3, MGASA-2026-0183, UBUNTU-CVE-2026-33250, USN-8754-1, openSUSE-SU-2026:10401-1, openSUSE-SU-2026:20423-1

## What is CVE-2026-33250?

CVE-2026-33250 is a high-severity vulnerability in longturn freeciv21, published on 23 Mar 2026. 

### Official description

Freeciv21 is a free open source, turn-based, empire-building strategy game. Versions prior to 3.1.1 crash with a stack overflow when receiving specially-crafted packets. A remote attacker can use this to take down any public server. A malicious server can use this to crash the game on the player's machine. Authentication is not needed and, by default, logs do not contain any useful information. All users should upgrade to Freeciv21 version 3.1.1. Running the server behind a firewall can help mitigate the issue for non-public servers. For local games, Freeciv21 restricts connections to the current user and is therefore not affected.

Weakness: CWE-20 (Improper Input Validation), CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2026-33250?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `freeciv` | openSUSE:Leap 16.0 | All versions | 3.2.4-bp160.1.1 |
| `freeciv` | openSUSE:Tumbleweed | All versions | 3.2.4-1.1 |

## How do I fix CVE-2026-33250?

Upgrade to a fixed version.

## Is CVE-2026-33250 being exploited?

There is no known exploitation of CVE-2026-33250 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33250 and fix it if it is affected.

What it is: CVE-2026-33250 is a high-severity vulnerability in longturn freeciv21, published on 23 Mar 2026. 
Exploitation: There is no known exploitation of CVE-2026-33250 in the wild and no public exploit code.

Affected product: longturn freeciv21. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33250/ (Markdown: https://insights.sbomify.com/CVE-2026-33250/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33250
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33250
- OSV: https://osv.dev/vulnerability/CVE-2026-33250

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33250/
Summaries are generated and may contain mistakes; the official description above is the record.
