# CVE-2026-33264: Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize()

> A DAG author can achieve remote code execution on the Airflow API Server or Scheduler by embedding a malicious trigger in a serialized DAG.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** BIT-airflow-2026-33264, CLEANSTART-2026-VP80273, ECHO-6322-53ef-9b9b, GHSA-2943-9672-r45w, MINI-7fwf-324x-vj47, MINI-fx8v-h2v8-p4cw, PYSEC-2026-2082

## What is CVE-2026-33264?

CVE-2026-33264 is a critical unsafe deserialization vulnerability in Apache Airflow, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A bug in `BaseSerialization.deserialize()` allowed unrestricted `import_string()` of attacker-controlled class paths when the Scheduler / API Server loaded a serialized DAG: a DAG author could embed a malicious trigger into a DAG to gain remote code execution on the API Server / Scheduler process, crossing the Airflow security boundary that DAG-author code must never execute in those processes. Users are advised to upgrade to `apache-airflow` 3.3.0 or later. As a defense-in-depth mitigation, deployments where DAG-author trust is limited can restrict the `[core] allowed_deserialization_classes` config to a narrow allowlist.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-33264?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 3.3.0 |
| `apache-airflow` | PyPI | All versions | 3.3.0 |
| `apache-airflow` | PyPI | All versions | 3.3.0 |
| `airflow` | Bitnami | All versions | 3.3.0 |

Products: Apache Airflow.

## How do I fix CVE-2026-33264?

Upgrade apache-airflow to 3.3.0 or later.

## Is CVE-2026-33264 being exploited?

There is no known exploitation of CVE-2026-33264 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)
- [CVE-2022-38649](https://insights.sbomify.com/CVE-2022-38649/): Apache Airflow Pinot provider allowed Command Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33264 and fix it if it is affected.

What it is: CVE-2026-33264 is a critical unsafe deserialization vulnerability in Apache Airflow, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33264 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 3.3.0
- apache-airflow (PyPI): affected all versions; fixed in 3.3.0
- apache-airflow (PyPI): affected all versions; fixed in 3.3.0
- airflow (Bitnami): affected all versions; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33264/ (Markdown: https://insights.sbomify.com/CVE-2026-33264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33264
- OSV: https://osv.dev/vulnerability/CVE-2026-33264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33264/
Summaries are generated and may contain mistakes; the official description above is the record.
