CVE-2026-33267 Apache Traffic Server: Untrusted @ headers can spoof ATS internal metadata
Attackers can spoof internal metadata using untrusted headers, potentially bypassing security controls in Apache Traffic Server.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33267?
CVE-2026-33267 is a high-severity vulnerability in Apache Traffic Server, published on 29 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Input Validation vulnerability in Apache Traffic Server.
This issue affects Apache Traffic Server: from 9.2.0 through 9.2.14, from 10.1.0 through 10.1.3.
Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fixes the issue.
Weakness: CWE-20
Which versions are affected by CVE-2026-33267?
It affects 1 product.
Products include Apache Traffic Server.
How do I fix CVE-2026-33267?
Upgrade to a fixed version.
Is CVE-2026-33267 being exploited?
There is no known exploitation of CVE-2026-33267 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Traffic Server
Sources
Also known as DEBIAN-CVE-2026-33267, GHSA-jrh6-9hgv-mqm7, UBUNTU-CVE-2026-33267.