{"answers":{"affected":"2 open source packages ship an affected version, including graphiti. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-33286 in the wild and no public exploit code.","fix":"Upgrade graphiti to 1.10.2 or later.","what":"CVE-2026-33286 is a critical code injection vulnerability in graphiti-api graphiti, published on 23 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-33286 and fix it if it is affected.\n\nWhat it is: CVE-2026-33286 is a critical code injection vulnerability in graphiti-api graphiti, published on 23 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-33286 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- graphiti (RubyGems): affected all versions; fixed in 1.10.2\n- graphiti (RubyGems): affected all versions; fixed in 1.10.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33286/ (Markdown: https://insights.sbomify.com/CVE-2026-33286/index.md)","id":"CVE-2026-33286","markdown":"https://insights.sbomify.com/CVE-2026-33286/index.md","name":"CVE-2026-33286","record":{"aliases":["GHSA-3m5v-4xp5-gjg2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby JSONAPI framework","requires_auth":"none","summary":"Attackers can execute arbitrary methods on model instances via malicious JSONAPI payloads in Graphiti, leading to code execution or data modification.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"graphiti","vendor":"graphiti"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-913","name":"Improper Control of Dynamically-Managed Code Resources"}],"description":"Graphiti is a framework that sits on top of models and exposes them via a JSON:API-compliant interface. Versions prior to 1.10.2 have an arbitrary method execution vulnerability that affects Graphiti's JSONAPI write functionality. An attacker can craft a malicious JSONAPI payload with arbitrary relationship names to invoke any public method on the underlying model instance, class or its associations. Any application exposing Graphiti write endpoints (create/update/delete) to untrusted users is affected. The `Graphiti::Util::ValidationResponse#all_valid?` method recursively calls `model.send(name)` using relationship names taken directly from user-supplied JSONAPI payloads, without validating them against the resource's configured sideloads. This allows an attacker to potentially run any public method on a given model instance, on the instance class or associated instances or classes, including destructive operations. This is patched in Graphiti v1.10.2. Users should upgrade as soon as possible. Some workarounds are available. Ensure Graphiti write endpoints (create/update) are not accessible to untrusted users and/or apply strong authentication and authorization checks before any write operation is processed, for example use Rails strong parameters to ensure only valid parameters are processed.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Graphiti Affected by Arbitrary Method Execution via Unvalidated Relationship Names","id":"CVE-2026-33286","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"LiquidJS has Exponential Memory Amplification through its replace_first Filter $\u0026 Pattern","id":"CVE-2026-33287"},"packages":[{"ecosystem":"RubyGems","fixed":["1.10.2"],"introduced":["0"],"last_affected":[],"package":"graphiti","purl":null,"source":"GHSA-3m5v-4xp5-gjg2"},{"ecosystem":"RubyGems","fixed":["1.10.2"],"introduced":["0"],"last_affected":[],"package":"graphiti","purl":"pkg:gem/graphiti","source":"GHSA-3m5v-4xp5-gjg2"}],"prev":{"headline":"LiquidJS: memoryLimit Bypass through Negative Range Values Leads to Process Crash","id":"CVE-2026-33285"},"products":["graphiti"],"published":"2026-03-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-24","vendors":["graphiti-api"]},"summary":"Attackers can execute arbitrary methods on model instances via malicious JSONAPI payloads in Graphiti, leading to code execution or data modification.","url":"https://insights.sbomify.com/CVE-2026-33286/"}