CVE-2026-33307 mod_gnutils has stack-based buffer overflow caused by a long client certificate chain
A stack-based buffer overflow in mod_gnutls allows remote attackers to cause a denial of service via a long client certificate chain when client verification is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-33307?
CVE-2026-33307 is a high-severity memory corruption vulnerability in airtower-luna mod_gnutls, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Mod_gnutls is a TLS module for Apache HTTPD based on GnuTLS. In versions prior to 0.12.3 and 0.13.0, code for client certificate verification imported the certificate chain sent by the client into a fixed size `gnutls_x509_crt_t x509[]` array without checking the number of certificates is less than or equal to the array size. `gnutls_x509_crt_t` is a `typedef` for a pointer to an opaque GnuTLS structure created using with `gnutls_x509_crt_init()` before importing certificate data into it, so no attacker-controlled data was written into the stack buffer, but writing a pointer after the last array element generally triggered a segfault, and could theoretically cause stack corruption otherwise (not observed in practice). Server configurations that do not use client certificates (`GnuTLSClientVerify ignore`, the default) are not affected. The problem has been fixed in version 0.12.3 by checking the length of the provided certificate chain and rejecting it if it exceeds the buffer length, and in version 0.13.0 by rewriting certificate verification to use `gnutls_certificate_verify_peers()`, removing the need for the buffer entirely. There is no workaround. Version 0.12.3 provides the minimal fix for users of 0.12.x who do not wish to upgrade to 0.13.0 yet.
Weakness: CWE-121
Which versions are affected by CVE-2026-33307?
It affects 1 product.
Products include Mod Gnutls Project Mod Gnutls.
How do I fix CVE-2026-33307?
No fix has been published for CVE-2026-33307 yet. Limit exposure of the affected software until one is available.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-33307 being exploited?
There is no known exploitation of CVE-2026-33307 in the wild and no public exploit code.
Other vulnerabilities in airtower-luna mod_gnutls
Sources
Also known as GHSA-gjpm-55p4-c76r, UBUNTU-CVE-2026-33307.