{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-33307 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-33307 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-33307 is a high-severity memory corruption vulnerability in airtower-luna mod_gnutls, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-33307 and fix it if it is affected.\n\nWhat it is: CVE-2026-33307 is a high-severity memory corruption vulnerability in airtower-luna mod_gnutls, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-33307 in the wild and no public exploit code.\n\nAffected product: airtower-luna mod_gnutls. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33307/ (Markdown: https://insights.sbomify.com/CVE-2026-33307/index.md)","id":"CVE-2026-33307","markdown":"https://insights.sbomify.com/CVE-2026-33307/index.md","name":"CVE-2026-33307","record":{"aliases":["GHSA-gjpm-55p4-c76r","UBUNTU-CVE-2026-33307"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache TLS module","requires_auth":"none","summary":"A stack-based buffer overflow in mod_gnutls allows remote attackers to cause a denial of service via a long client certificate chain when client verification is enabled.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"mod_gnutls","vendor":"mod_gnutls_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-121","name":"Stack-based Buffer Overflow"}],"description":"Mod_gnutls is a TLS module for Apache HTTPD based on GnuTLS. In versions prior to 0.12.3 and 0.13.0, code for client certificate verification imported the certificate chain sent by the client into a fixed size `gnutls_x509_crt_t x509[]` array without checking the number of certificates is less than or equal to the array size. `gnutls_x509_crt_t` is a `typedef` for a pointer to an opaque GnuTLS structure created using with `gnutls_x509_crt_init()` before importing certificate data into it, so no attacker-controlled data was written into the stack buffer, but writing a pointer after the last array element generally triggered a segfault, and could theoretically cause stack corruption otherwise (not observed in practice). Server configurations that do not use client certificates (`GnuTLSClientVerify ignore`, the default) are not affected. The problem has been fixed in version 0.12.3 by checking the length of the provided certificate chain and rejecting it if it exceeds the buffer length, and in version 0.13.0 by rewriting certificate verification to use `gnutls_certificate_verify_peers()`, removing the need for the buffer entirely. There is no workaround. Version 0.12.3 provides the minimal fix for users of 0.12.x who do not wish to upgrade to 0.13.0 yet.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"mod_gnutils has stack-based buffer overflow caused by a long client certificate chain","id":"CVE-2026-33307","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"mod_gnutls missing key purpose check in client certificate verification","id":"CVE-2026-33308"},"packages":[],"prev":{"headline":"bcrypt-ruby has an Integer Overflow that Causes Zero Key-Strengthening Iterations at Cost=31 on JRuby","id":"CVE-2026-33306"},"products":["mod_gnutls"],"published":"2026-03-24","related":[{"cvss_score":7.5,"headline":"mod_gnutls contains Infinite Loop on request read timeout","id":"CVE-2023-25824","kev_date_added":null,"published":"2023-02-23"},{"cvss_score":7.5,"headline":"Auth bypass in n/a","id":"CVE-2009-5144","kev_date_added":null,"published":"2018-02-03"},{"cvss_score":6.8,"headline":"mod_gnutls missing key purpose check in client certificate verification","id":"CVE-2026-33308","kev_date_added":null,"published":"2026-03-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-24","vendors":["airtower-luna"]},"summary":"A stack-based buffer overflow in mod_gnutls allows remote attackers to cause a denial of service via a long client certificate chain when client verification is enabled.","url":"https://insights.sbomify.com/CVE-2026-33307/"}