# CVE-2026-33307: mod_gnutils has stack-based buffer overflow caused by a long client certificate chain

> A stack-based buffer overflow in mod_gnutls allows remote attackers to cause a denial of service via a long client certificate chain when client verification is enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** GHSA-gjpm-55p4-c76r, UBUNTU-CVE-2026-33307

## What is CVE-2026-33307?

CVE-2026-33307 is a high-severity memory corruption vulnerability in airtower-luna mod_gnutls, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mod_gnutls is a TLS module for Apache HTTPD based on GnuTLS. In versions prior to 0.12.3 and 0.13.0, code for client certificate verification imported the certificate chain sent by the client into a fixed size `gnutls_x509_crt_t x509[]` array without checking the number of certificates is less than or equal to the array size. `gnutls_x509_crt_t` is a `typedef` for a pointer to an opaque GnuTLS structure created using with `gnutls_x509_crt_init()` before importing certificate data into it, so no attacker-controlled data was written into the stack buffer, but writing a pointer after the last array element generally triggered a segfault, and could theoretically cause stack corruption otherwise (not observed in practice). Server configurations that do not use client certificates (`GnuTLSClientVerify ignore`, the default) are not affected. The problem has been fixed in version 0.12.3 by checking the length of the provided certificate chain and rejecting it if it exceeds the buffer length, and in version 0.13.0 by rewriting certificate verification to use `gnutls_certificate_verify_peers()`, removing the need for the buffer entirely. There is no workaround. Version 0.12.3 provides the minimal fix for users of 0.12.x who do not wish to upgrade to 0.13.0 yet.

Weakness: CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2026-33307?

It affects 1 product.


Products: Mod Gnutls Project Mod Gnutls.

## How do I fix CVE-2026-33307?

No fix has been published for CVE-2026-33307 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-33307 being exploited?

There is no known exploitation of CVE-2026-33307 in the wild and no public exploit code.

## Other vulnerabilities in airtower-luna mod_gnutls

- [CVE-2023-25824](https://insights.sbomify.com/CVE-2023-25824/): mod_gnutls contains Infinite Loop on request read timeout (high 7.5)
- [CVE-2009-5144](https://insights.sbomify.com/CVE-2009-5144/): Auth bypass in n/a (high 7.5)
- [CVE-2026-33308](https://insights.sbomify.com/CVE-2026-33308/): mod_gnutls missing key purpose check in client certificate verification (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33307 and fix it if it is affected.

What it is: CVE-2026-33307 is a high-severity memory corruption vulnerability in airtower-luna mod_gnutls, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33307 in the wild and no public exploit code.

Affected product: airtower-luna mod_gnutls. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33307/ (Markdown: https://insights.sbomify.com/CVE-2026-33307/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33307
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33307
- OSV: https://osv.dev/vulnerability/CVE-2026-33307

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33307/
Summaries are generated and may contain mistakes; the official description above is the record.
