{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-33308 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-33308 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-33308 is a medium-severity authentication bypass vulnerability in airtower-luna mod_gnutls, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-33308 and fix it if it is affected.\n\nWhat it is: CVE-2026-33308 is a medium-severity authentication bypass vulnerability in airtower-luna mod_gnutls, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-33308 in the wild and no public exploit code.\n\nAffected product: airtower-luna mod_gnutls. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33308/ (Markdown: https://insights.sbomify.com/CVE-2026-33308/index.md)","id":"CVE-2026-33308","markdown":"https://insights.sbomify.com/CVE-2026-33308/index.md","name":"CVE-2026-33308","record":{"aliases":["GHSA-hm2g-m958-8qgh","UBUNTU-CVE-2026-33308"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache TLS module","requires_auth":"none","summary":"Attackers can bypass TLS client authentication using certificates with incorrect key purposes, requiring specific server configurations.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"mod_gnutls","vendor":"mod_gnutls_project"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Mod_gnutls is a TLS module for Apache HTTPD based on GnuTLS. Prior to version 0.13.0, code for client certificate verification did not check the key purpose as set in the Extended Key Usage extension. An attacker with access to the private key for a valid certificate issued by a CA trusted for TLS client authentication but designated for a different purpose could have used that certificate to improperly access resources requiring TLS client authentication. Server configurations that do not use client certificates (`GnuTLSClientVerify ignore`, the default) are not affected. The problem has been fixed in version 0.13.0 by rewriting certificate verification to use `gnutls_certificate_verify_peers()`, and requiring key purpose id-kp-clientAuth (also known as `tls_www_client` in GnuTLS) by default if the Extended Key Usage extension is present. The new `GnuTLSClientKeyPurpose` option allows overriding the expected key purpose if needed (please see the manual for details). Behavior for certificates without an Extended Key Usage extension is unchanged. If dedicated (sub-)CAs are used for issuing TLS client certificates only (not for any other purposes) the issue has no practical impact.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"mod_gnutls missing key purpose check in client certificate verification","id":"CVE-2026-33308","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Langflow has an Arbitrary File Write (RCE) via v2 API","id":"CVE-2026-33309"},"packages":[],"prev":{"headline":"mod_gnutils has stack-based buffer overflow caused by a long client certificate chain","id":"CVE-2026-33307"},"products":["mod_gnutls"],"published":"2026-03-24","related":[{"cvss_score":7.5,"headline":"mod_gnutils has stack-based buffer overflow caused by a long client certificate chain","id":"CVE-2026-33307","kev_date_added":null,"published":"2026-03-24"},{"cvss_score":7.5,"headline":"mod_gnutls contains Infinite Loop on request read timeout","id":"CVE-2023-25824","kev_date_added":null,"published":"2023-02-23"},{"cvss_score":7.5,"headline":"Auth bypass in n/a","id":"CVE-2009-5144","kev_date_added":null,"published":"2018-02-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-24","vendors":["airtower-luna"]},"summary":"Attackers can bypass TLS client authentication using certificates with incorrect key purposes, requiring specific server configurations.","url":"https://insights.sbomify.com/CVE-2026-33308/"}