# CVE-2026-33309: Langflow has an Arbitrary File Write (RCE) via v2 API

> Authenticated attackers can bypass file name validation to write arbitrary files on the host, leading to remote code execution in Langflow.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2026
- **Updated:** 25 Mar 2026
- **Also known as:** ECHO-6551-da8d-a4b8, GHSA-g2j9-7rj2-gm6c, PYSEC-2026-79

## What is CVE-2026-33309?

CVE-2026-33309 is a critical path traversal vulnerability in Langflow Langflow, published on 24 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Langflow is a tool for building and deploying AI-powered agents and workflows. Versions 1.2.0 through 1.8.1 have a bypass of the patch for CVE-2025-68478 (External Control of File Name), leading to the root architectural issue within `LocalStorageService` remaining unresolved. Because the underlying storage layer lacks boundary containment checks, the system relies entirely on the HTTP-layer `ValidatedFileName` dependency. This defense-in-depth failure leaves the `POST /api/v2/files/` endpoint vulnerable to Arbitrary File Write. The multipart upload filename bypasses the path-parameter guard, allowing authenticated attackers to write files anywhere on the host system, leading to Remote Code Execution (RCE). Version 1.9.0 contains an updated fix.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-284 (Improper Access Control), CWE-73 (External Control of File Name or Path), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-33309?

3 open source packages ship an affected version, including langflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langflow` | PyPI | From 1.2.0 | 1.9.0 |
| `langflow` | PyPI | From 1.2.0 | 1.9.0 |
| `langflow` | PyPI | From 1.2.0 | 1.9.0 |

Products: Langflow Langflow.

## How do I fix CVE-2026-33309?

Upgrade langflow to 1.9.0 or later.

## Is CVE-2026-33309 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33309 exists.

## Other vulnerabilities in Langflow Langflow

- [CVE-2026-9198](https://insights.sbomify.com/CVE-2026-9198/): IBM Langflow Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-0770](https://insights.sbomify.com/CVE-2026-0770/): Langflow Inclusion of Functionality from Untrusted Control Sphere (critical 9.8, exploited in the wild)
- [CVE-2025-3248](https://insights.sbomify.com/CVE-2025-3248/): Langflow Missing Authentication (critical 9.8, exploited in the wild)
- [CVE-2025-34291](https://insights.sbomify.com/CVE-2025-34291/): Langflow Origin Validation Error (critical 9.4, exploited in the wild)
- [CVE-2026-33017](https://insights.sbomify.com/CVE-2026-33017/): Langflow Code Injection (critical 9.3, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33309 and fix it if it is affected.

What it is: CVE-2026-33309 is a critical path traversal vulnerability in Langflow Langflow, published on 24 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33309 exists.

Affected packages and fixed versions:
- langflow (PyPI): affected from 1.2.0; fixed in 1.9.0
- langflow (PyPI): affected from 1.2.0; fixed in 1.9.0
- langflow (PyPI): affected from 1.2.0; fixed in 1.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33309/ (Markdown: https://insights.sbomify.com/CVE-2026-33309/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33309
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33309
- OSV: https://osv.dev/vulnerability/CVE-2026-33309

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33309/
Summaries are generated and may contain mistakes; the official description above is the record.
