# CVE-2026-33310: Intake has a Command Injection via shell() Expansion in Parameter Defaults

> Attackers can execute arbitrary commands on the host system by tricking users into loading a malicious catalog YAML file in the Intake library.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** GHSA-37g4-qqqv-7m99, PYSEC-2026-2185, openSUSE-SU-2026:10426-1

## What is CVE-2026-33310?

CVE-2026-33310 is a high-severity command injection vulnerability in intake, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Intake is a package for finding, investigating, loading and disseminating data. Prior to version 2.0.9, the shell() syntax within parameter default values appears to be automatically expanded during the catalog parsing process. If a catalog contains a parameter default such as shell(<command>), the command may be executed when the catalog source is accessed. This means that if a user loads a malicious catalog YAML, embedded commands could execute on the host system. Version 2.0.9 mitigates the issue by making getshell False by default everywhere.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-33310?

3 open source packages ship an affected version, including intake. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `intake` | PyPI | All versions to 2.0.9 | None |
| `intake` | PyPI | All versions to 2.0.9 | None |
| `intake` | PyPI | All versions | 2.0.9 |
| `python-intake` | openSUSE:Tumbleweed | All versions | 2.0.9-1.1 |

Products: Intake Intake.

## How do I fix CVE-2026-33310?

Upgrade intake to 2.0.9 or later.

## Is CVE-2026-33310 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33310 exists.

Public exploit code:

- CVE-2026-33310(Command Injection via shell() Expansion in Parameter Defaults) (github_poc): https://github.com/redyank/CVE-2026-33310

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33310 and fix it if it is affected.

What it is: CVE-2026-33310 is a high-severity command injection vulnerability in intake, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33310 exists.

Affected packages and fixed versions:
- intake (PyPI): affected all versions up to 2.0.9; no fix listed
- intake (PyPI): affected all versions up to 2.0.9; no fix listed
- intake (PyPI): affected all versions; fixed in 2.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33310/ (Markdown: https://insights.sbomify.com/CVE-2026-33310/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33310
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33310
- OSV: https://osv.dev/vulnerability/CVE-2026-33310

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33310/
Summaries are generated and may contain mistakes; the official description above is the record.
