{"answers":{"affected":"2 open source packages ship an affected version, including @actual-app/sync-server. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33318 exists.","fix":"Upgrade @actual-app/sync-server to 26.4.0 or later.","what":"CVE-2026-33318 is a high-severity vulnerability in actualbudget actual, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-33318 and fix it if it is affected.\n\nWhat it is: CVE-2026-33318 is a high-severity vulnerability in actualbudget actual, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33318 exists.\n\nAffected packages and fixed versions:\n- @actual-app/sync-server (npm): affected all versions; fixed in 26.4.0\n- @actual-app/sync-server (npm): affected all versions; fixed in 26.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33318/ (Markdown: https://insights.sbomify.com/CVE-2026-33318/index.md)","id":"CVE-2026-33318","markdown":"https://insights.sbomify.com/CVE-2026-33318/index.md","name":"CVE-2026-33318","record":{"aliases":["GHSA-prp4-2f49-fcgp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Personal finance tool","requires_auth":"low_privilege","summary":"Authenticated users can escalate to admin on servers migrated from password auth to OpenID Connect by exploiting a missing authorization check and orphaned credentials.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"actual","vendor":"actualbudget"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"},{"id":"CWE-284","name":"Improper Access Control"}],"description":"Actual is a local-first personal finance tool. Prior to version 26.4.0, any authenticated user (including `BASIC` role) can escalate to `ADMIN` on servers migrated from password authentication to OpenID Connect. Three weaknesses combine: `POST /account/change-password` has no authorization check, allowing any session to overwrite the password hash; the inactive password `auth` row is never removed on migration; and the login endpoint accepts a client-supplied `loginMethod` that bypasses the server's active auth configuration. Together these allow an attacker to set a known password and authenticate as the anonymous admin account created during the multiuser migration. The three weaknesses form a single, sequential exploit chain — none produces privilege escalation on its own. Missing authorization on POST /change-password allows overwriting a password hash, but only matters if there is an orphaned row to target. Orphaned password row persisting after migration provides the target row, but is harmless without the ability to authenticate using it. Client-controlled loginMethod: \"password\" allows forcing password-based auth, but is useless without a known hash established by step 1. All three must be chained in sequence to achieve the impact. No single weakness independently results in privilege escalation. The single root cause is the missing authorization check on /change-password; the other two are preconditions that make it exploitable. Version 26.4.0 contains a fix.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Actual has Privilege Escalation via 'change-password' Endpoint on OpenID-Migrated Servers","id":"CVE-2026-33318","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"AVideo Vulnerable to OS Command Injection via Unescaped URL in LinkedIn Video Upload Shell Command","id":"CVE-2026-33319"},"packages":[{"ecosystem":"npm","fixed":["26.4.0"],"introduced":["0"],"last_affected":[],"package":"@actual-app/sync-server","purl":null,"source":"GHSA-prp4-2f49-fcgp"},{"ecosystem":"npm","fixed":["26.4.0"],"introduced":["0"],"last_affected":[],"package":"@actual-app/sync-server","purl":"pkg:npm/%40actual-app/sync-server","source":"GHSA-prp4-2f49-fcgp"}],"prev":{"headline":"OP-TEE: PKCS#11 TA out-of-bounds read and memory disclosure","id":"CVE-2026-33317"},"products":["actual"],"published":"2026-04-24","related":[{"cvss_score":9.2,"headline":"ActualBudget server is Missing Authentication for SimpleFIN and Pluggy AI bank sync endpoints","id":"CVE-2026-27584","kev_date_added":null,"published":"2026-02-24"},{"cvss_score":5.7,"headline":"ActualBudget missing authorization in sync endpoints allows cross-user budget file access in multi-user mode","id":"CVE-2026-27638","kev_date_added":null,"published":"2026-02-26"},{"cvss_score":5.3,"headline":"Actual Sync Server 26.2.1 - Authenticated Path Traversal","id":"CVE-2026-3089","kev_date_added":null,"published":"2026-03-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-25","vendors":["actualbudget"]},"summary":"Authenticated users can escalate to admin on servers migrated from password auth to OpenID Connect by exploiting a missing authorization check and orphaned credentials.","url":"https://insights.sbomify.com/CVE-2026-33318/"}