CVE-2026-33327 Possible integer overflow leading to potential heap-based buffer overflow

High 7.0 Published Updated

An integer overflow in libvips can lead to a heap-based buffer overflow, potentially allowing code execution or denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33327?

CVE-2026-33327 is a high-severity vulnerability in libvips, published on 20 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

libvips is a fast image processing library with low memory needs. The `vipsload` operation in versions before and including 8.18.0 could incorrectly determine image dimensions leading to an integer overflow and a subsequent heap-based buffer overflow. This has been patched in version 8.18.1.

Weakness: CWE-190

Which versions are affected by CVE-2026-33327?

It affects 1 product.

Products include Libvips Libvips.

How do I fix CVE-2026-33327?

Upgrade to a fixed version.

Is CVE-2026-33327 being exploited?

There is no known exploitation of CVE-2026-33327 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2026-RC96450, DEBIAN-CVE-2026-33327, GHSA-2fcj-gj27-279x, UBUNTU-CVE-2026-33327.

Is CVE-2026-33327 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free