CVE-2026-33328 Possible integer overflow on 32-bit systems when reading GIF images

Medium 6.8 Published Updated

An integer overflow in libvips on 32-bit systems when reading GIF images can lead to denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33328?

CVE-2026-33328 is a medium-severity vulnerability in libvips, published on 20 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

libvips is a fast image processing library with low memory needs. On 32-bit systems in versions before and including 8.18.0, the `gifload` operation could incorrectly determine dimensions leading to an integer overflow. This has been patched in version 8.18.1.

Weakness: CWE-190

Which versions are affected by CVE-2026-33328?

It affects 1 product.

Products include Libvips Libvips.

How do I fix CVE-2026-33328?

Upgrade to a fixed version.

Is CVE-2026-33328 being exploited?

There is no known exploitation of CVE-2026-33328 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2026-XT37855, DEBIAN-CVE-2026-33328, GHSA-r98w-4fp7-m9c7, UBUNTU-CVE-2026-33328.

Is CVE-2026-33328 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free