CVE-2026-33337 Firebird has a buffer overflow when parsing corrupted slice packets
An unauthenticated attacker can cause a buffer overflow in Firebird database by sending a crafted slice packet, leading to crashes or potential code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33337?
CVE-2026-33337 is a high-severity memory corruption vulnerability in FirebirdSQL firebird, published on 17 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and 3.0.14, when deserializing a slice packet, the xdr_datum() function does not validate that a cstring length conforms to the slice descriptor bounds, allowing a cstring longer than the allocated buffer to overflow it. An unauthenticated attacker can exploit this by sending a crafted packet to the server, potentially causing a crash or other security impact. This issue has been fixed in versions 5.0.4, 4.0.7 and 3.0.14.
Which versions are affected by CVE-2026-33337?
It affects 1 product.
Products include Firebirdsql Firebird.
How do I fix CVE-2026-33337?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-33337 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33337 exists.
Other vulnerabilities in FirebirdSQL firebird
Sources
Also known as DEBIAN-CVE-2026-33337, ECHO-0388-1371-3776, GHSA-89mq-229g-x47p, UBUNTU-CVE-2026-33337.