# CVE-2026-33347: league/commonmark has an embed extension allowed_domains bypass

> Attackers can bypass domain allowlists in the Embed extension, potentially enabling SSRF or XSS via malicious domains.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2026
- **Updated:** 26 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-33347, GHSA-hh8v-hgvp-g3f5, UBUNTU-CVE-2026-33347

## What is CVE-2026-33347?

CVE-2026-33347 is a medium-severity vulnerability in thephpleague commonmark, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

league/commonmark is a PHP Markdown parser. From version 2.3.0 to before version 2.8.2, the DomainFilteringAdapter in the Embed extension is vulnerable to an allowlist bypass due to a missing hostname boundary assertion in the domain-matching regex. An attacker-controlled domain like youtube.com.evil passes the allowlist check when youtube.com is an allowed domain. This issue has been patched in version 2.8.2.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-185 (Incorrect Regular Expression)

## Which versions are affected by CVE-2026-33347?

2 open source packages ship an affected version, including league/commonmark. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `league/commonmark` | Packagist | From 2.3.0 | 2.8.2 |
| `league/commonmark` | Packagist | From 2.3.0 | 2.8.2 |

Products: Thephpleague Commonmark.

## How do I fix CVE-2026-33347?

Upgrade league/commonmark to 2.8.2 or later.

## Is CVE-2026-33347 being exploited?

There is no known exploitation of CVE-2026-33347 in the wild and no public exploit code.

## Other vulnerabilities in thephpleague commonmark

- [CVE-2026-86428](https://insights.sbomify.com/CVE-2026-86428/): commonmark 1.5.0 before 2.10.0 Denial of Service via Attributes (high 8.7)
- [CVE-2026-86429](https://insights.sbomify.com/CVE-2026-86429/): commonmark before 2.9.1 Denial of Service via SmartPunct and Attributes (high 8.7)
- [CVE-2026-86430](https://insights.sbomify.com/CVE-2026-86430/): league/commonmark before 2.9.1 Denial of Service via parsing (high 8.7)
- [CVE-2026-86431](https://insights.sbomify.com/CVE-2026-86431/): commonmark before 2.9.1 XSS via AttributesExtension form feed bypass (medium 6.9)
- [CVE-2019-10010](https://insights.sbomify.com/CVE-2019-10010/): Moderate severity vulnerability that affects league/commonmark (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33347 and fix it if it is affected.

What it is: CVE-2026-33347 is a medium-severity vulnerability in thephpleague commonmark, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33347 in the wild and no public exploit code.

Affected packages and fixed versions:
- league/commonmark (Packagist): affected from 2.3.0; fixed in 2.8.2
- league/commonmark (Packagist): affected from 2.3.0; fixed in 2.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33347/ (Markdown: https://insights.sbomify.com/CVE-2026-33347/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33347
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33347
- OSV: https://osv.dev/vulnerability/CVE-2026-33347

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33347/
Summaries are generated and may contain mistakes; the official description above is the record.
