CVE-2026-3336 PKCS7_verify Certificate Chain Validation Bypass in AWS-LC
An attacker can bypass certificate chain verification in PKCS7 objects with multiple signers, requiring applications using AWS-LC to upgrade.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-3336?
CVE-2026-3336 is a high-severity vulnerability in AWS-LC, published on 2 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper certificate validation in PKCS7_verify() in AWS-LC allows an unauthenticated user to bypass certificate chain verification when processing PKCS7 objects with multiple signers, except the final signer.
Customers of AWS services do not need to take action. Applications using AWS-LC should upgrade to AWS-LC version 1.69.0.
Weakness: CWE-295
Which versions are affected by CVE-2026-3336?
3 open source packages ship an affected version, including aws-lc-sys. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
aws-lc-sys crates.io | From 0.24.0 | 0.38.0 |
aws-lc-sys crates.io | From 0.24.0 | 0.38.0 |
aws-lc-sys crates.io | From 0.24.0 | 0.38.0 |
Products include Amazon Aws-Lc-Sys, Amazon Aws Libcrypto.
How do I fix CVE-2026-3336?
Upgrade aws-lc-sys to 0.38.0 or later.
Is CVE-2026-3336 being exploited?
There is no known exploitation of CVE-2026-3336 in the wild and no public exploit code.
Other vulnerabilities in AWS-LC
Sources
Also known as CLEANSTART-2026-GZ43069, GHSA-cfwj-9wp5-wqvp, GHSA-vw5v-4f2q-w9xf, MINI-223r-3h77-3xxx, MINI-244g-9xfv-46c6, MINI-3c4c-9jfx-p4qf and 14 more.