{"answers":{"affected":"3 open source packages ship an affected version, including aws-lc-sys. It affects 2 products.","exploited":"There is no known exploitation of CVE-2026-3336 in the wild and no public exploit code.","fix":"Upgrade aws-lc-sys to 0.38.0 or later.","what":"CVE-2026-3336 is a high-severity vulnerability in AWS-LC, published on 2 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-3336 and fix it if it is affected.\n\nWhat it is: CVE-2026-3336 is a high-severity vulnerability in AWS-LC, published on 2 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-3336 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aws-lc-sys (crates.io): affected from 0.24.0; fixed in 0.38.0\n- aws-lc-sys (crates.io): affected from 0.24.0; fixed in 0.38.0\n- aws-lc-sys (crates.io): affected from 0.24.0; fixed in 0.38.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-3336/ (Markdown: https://insights.sbomify.com/CVE-2026-3336/index.md)","id":"CVE-2026-3336","markdown":"https://insights.sbomify.com/CVE-2026-3336/index.md","name":"CVE-2026-3336","record":{"aliases":["CLEANSTART-2026-GZ43069","GHSA-cfwj-9wp5-wqvp","GHSA-vw5v-4f2q-w9xf","MINI-223r-3h77-3xxx","MINI-244g-9xfv-46c6","MINI-3c4c-9jfx-p4qf","MINI-6ppp-65m3-9hp8","MINI-92wj-jqxx-929c","MINI-f5cc-f56w-59qg","MINI-ghh9-8r6m-3234","MINI-h7xc-76cq-w4p9","MINI-hvvv-9x3m-mcv4","MINI-pqwx-h8fq-4g5v","MINI-q49r-r9j6-35xf","MINI-qv3p-j3fj-g5f3","MINI-rg3g-vv8g-758h","MINI-v7c9-jhxp-5f3j","MINI-ww98-q9h9-45w9","MINI-x44f-vg22-x745","RUSTSEC-2026-0046"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"AWS-LC cryptographic library","requires_auth":"none","summary":"An attacker can bypass certificate chain verification in PKCS7 objects with multiple signers, requiring applications using AWS-LC to upgrade.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[{"product":"aws-lc-sys","vendor":"amazon"},{"product":"aws_libcrypto","vendor":"amazon"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Improper certificate validation in PKCS7_verify() in AWS-LC allows an unauthenticated user to bypass certificate chain verification when processing PKCS7 objects with multiple signers, except the final signer.\n\nCustomers of AWS services do not need to take action. Applications using AWS-LC should upgrade to AWS-LC version 1.69.0.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PKCS7_verify Certificate Chain Validation Bypass in AWS-LC","id":"CVE-2026-3336","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Timing Side-Channel in AES-CCM Tag Verification in AWS-LC","id":"CVE-2026-3337"},"packages":[{"ecosystem":"crates.io","fixed":["0.38.0"],"introduced":["0.24.0"],"last_affected":[],"package":"aws-lc-sys","purl":null,"source":"GHSA-vw5v-4f2q-w9xf"},{"ecosystem":"crates.io","fixed":["0.38.0"],"introduced":["0.24.0"],"last_affected":[],"package":"aws-lc-sys","purl":"pkg:cargo/aws-lc-sys","source":"GHSA-vw5v-4f2q-w9xf"},{"ecosystem":"crates.io","fixed":["0.38.0"],"introduced":["0.24.0"],"last_affected":[],"package":"aws-lc-sys","purl":"pkg:cargo/aws-lc-sys","source":"RUSTSEC-2026-0046"}],"prev":{"headline":"Canto \u003c= 3.1.1 - Missing Authorization to Unauthenticated File Upload","id":"CVE-2026-3335"},"products":["AWS-LC"],"published":"2026-03-02","related":[{"cvss_score":8.7,"headline":"PKCS7_verify Signature Validation Bypass in AWS-LC","id":"CVE-2026-3338","kev_date_added":null,"published":"2026-03-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-21","vendors":["AWS"]},"summary":"An attacker can bypass certificate chain verification in PKCS7 objects with multiple signers, requiring applications using AWS-LC to upgrade.","url":"https://insights.sbomify.com/CVE-2026-3336/"}