CVE-2026-33394 Discourse leaks PM post edits to moderators
Moderators can view private message content via the post edits admin report, exposing sensitive data to unauthorized users.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33394?
CVE-2026-33394 is a low-severity vulnerability in Discourse Discourse, published on 19 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, the Post Edits admin report (/admin/reports/post_edits) leaked the first 40 characters of raw post content from private messages and secure categories to moderators who shouldn't have access. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.
Weakness: CWE-200
Which versions are affected by CVE-2026-33394?
1 open source package ship an affected version, including discourse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | From 2026.1.0 | 2026.1.2, 2026.2.1, 2026.3.0 |
Products include Discourse Discourse.
How do I fix CVE-2026-33394?
Upgrade discourse to a fixed version for your release line: 2026.1.2, 2026.2.1 or 2026.3.0.
Is CVE-2026-33394 being exploited?
There is no known exploitation of CVE-2026-33394 in the wild and no public exploit code.
Other vulnerabilities in Discourse Discourse
- CVE-2021-41163 RCE via malicious SNS subscription payload
- CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file
- CVE-2022-39356 Discourse user account takeover via email and invite link
- CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes
- CVE-2026-27934 Discourse leaks private topic title and post excerpt via user action API endpoint
Sources
Also known as BIT-discourse-2026-33394, GHSA-wxvr-pm5c-829p.