CVE-2026-33397 Angular SSR Vulnerable to Protocol-Relative URL Injection via Single Backslash Bypass
Attackers can redirect users to malicious sites via a backslash bypass in Angular SSR when deployed behind a proxy, potentially enabling cache poisoning.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33397?
CVE-2026-33397 is a medium-severity vulnerability in angular-cli, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Angular SSR is a server-rise rendering tool for Angular applications. Versions on the 22.x branch prior to 22.0.0-next.2, the 21.x branch prior to 21.2.3, and the 20.x branch prior to 20.3.21 have an Open Redirect vulnerability in `@angular/ssr` due to an incomplete fix for CVE-2026-27738. While the original fix successfully blocked multiple leading slashes (e.g., `///`), the internal validation logic fails to account for a single backslash (`\`) bypass. When an Angular SSR application is deployed behind a proxy that passes the `X-Forwarded-Prefix` header, an attacker provides a value starting with a single backslash, the internal validation failed to flag the single backslash as invalid, the application prepends a leading forward slash, resulting in a `Location` header containing the URL, and modern browsers interpret the `/\` sequence as `//`, treating it as a protocol-relative URL and redirecting the user to the attacker-controlled domain. Furthermore, the response lacks the `Vary: X-Forwarded-Prefix` header, allowing the malicious redirect to be stored in intermediate caches (Web Cache Poisoning). Versions 22.0.0-next.2, 21.2.3, and 20.3.21 contain a patch. Until the patch is applied, developers should sanitize the `X-Forwarded-Prefix` header in their `server.ts` before the Angular engine processes the request.
Weakness: CWE-601
Which versions are affected by CVE-2026-33397?
6 open source packages ship an affected version, including @angular/ssr. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
@angular/ssr npm | From 20.0.0-next.0 | 20.3.21 |
@angular/ssr npm | From 20.0.0-next.0 | 20.3.21 |
@angular/ssr npm | From 21.0.0-next.0 | 21.2.3 |
@angular/ssr npm | From 21.0.0-next.0 | 21.2.3 |
@angular/ssr npm | From 22.0.0-next.0 | 22.0.0-next.2 |
@angular/ssr npm | From 22.0.0-next.0 | 22.0.0-next.2 |
Products include Angular Angular Cli.
How do I fix CVE-2026-33397?
Upgrade @angular/ssr to a fixed version for your release line: 20.3.21, 21.2.3 or 22.0.0-next.2.
Is CVE-2026-33397 being exploited?
There is no known exploitation of CVE-2026-33397 in the wild and no public exploit code.
Other vulnerabilities in angular-cli
Sources
Also known as GHSA-vfx2-hv2g-xj5f.