{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33403 exists.","fix":"No fix has been published for CVE-2026-33403 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-33403 is a medium-severity cross-site scripting vulnerability in pi-hole web, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-33403 and fix it if it is affected.\n\nWhat it is: CVE-2026-33403 is a medium-severity cross-site scripting vulnerability in pi-hole web, published on 6 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33403 exists.\n\nAffected product: pi-hole web. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33403/ (Markdown: https://insights.sbomify.com/CVE-2026-33403/index.md)","id":"CVE-2026-33403","markdown":"https://insights.sbomify.com/CVE-2026-33403/index.md","name":"CVE-2026-33403","record":{"aliases":["GHSA-7xqw-r9pr-qv59"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Pi-hole admin interface","requires_auth":"none","summary":"An unauthenticated attacker can inject HTML via a crafted URL to steal credentials from the Pi-hole admin interface due to improper output encoding.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"web_interface","vendor":"pi-hole"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Pi-hole Admin Interface is a web interface for managing Pi-hole, a network-level ad and internet tracker blocking application. From 6.0 to before 6.5, a reflected DOM-based XSS vulnerability in taillog.js allows an unauthenticated attacker to inject arbitrary HTML into the Pi-hole admin interface by crafting a malicious URL. The file query parameter is interpolated into an innerHTML assignment without escaping. Because the Content-Security-Policy is missing the form-action directive, injected \u003cform\u003e elements can exfiltrate credentials to an external origin. This vulnerability is fixed in 6.5.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Pi-hole has a Reflected XSS / HTML injection in taillog.js","id":"CVE-2026-33403","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Pi-hole has a Stored XSS / HTML injection in the Network page/Dashboard","id":"CVE-2026-33404"},"packages":[],"prev":{"headline":"SAK-52311: Sakai site-manage group titles can contain XSS content","id":"CVE-2026-33402"},"products":["web"],"published":"2026-04-06","related":[{"cvss_score":8.9,"headline":"Pi-hole Web Interface has a Command Injection Vulnerability","id":"CVE-2026-33765","kev_date_added":null,"published":"2026-03-27"},{"cvss_score":8.8,"headline":"Improper session handling of \"Remember me for 7 days\" functionality","id":"CVE-2023-23614","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":8.2,"headline":"Pi-hole Admin Interface vulnerable to HTTP response header injection via CRLF injection","id":"CVE-2025-59151","kev_date_added":null,"published":"2025-10-27"},{"cvss_score":7.4,"headline":"Sensitive Cookie Without 'HttpOnly' Flag in pi-hole/adminlte","id":"CVE-2021-3706","kev_date_added":null,"published":"2021-09-15"},{"cvss_score":7.3,"headline":"Stored XSS in Client Groups Management (Authenticated)","id":"CVE-2021-41175","kev_date_added":null,"published":"2021-10-26"},{"cvss_score":6.7,"headline":"Cross-site Scripting (XSS) - Reflected in pi-hole/adminlte","id":"CVE-2021-3811","kev_date_added":null,"published":"2021-09-17"},{"cvss_score":6.7,"headline":"Cross-site Scripting (XSS) - Reflected in pi-hole/adminlte","id":"CVE-2021-3812","kev_date_added":null,"published":"2021-09-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-06","vendors":["pi-hole"]},"summary":"An unauthenticated attacker can inject HTML via a crafted URL to steal credentials from the Pi-hole admin interface due to improper output encoding.","url":"https://insights.sbomify.com/CVE-2026-33403/"}