CVE-2026-33408 Discourse has Improper Authorization in "Post Edits" Report For Moderators

Low 2.2 Published Updated

Moderators can improperly view the first 40 characters of post edits in private messages and private categories, exposing sensitive content.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33408?

CVE-2026-33408 is a low-severity missing authorization vulnerability in Discourse Discourse, published on 19 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, moderators were able to see the first 40 characters of post edits in PMs and private categories. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.

Weakness: CWE-862

Which versions are affected by CVE-2026-33408?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiFrom 2026.1.02026.1.2, 2026.2.1, 2026.3.0

Products include Discourse Discourse.

How do I fix CVE-2026-33408?

Upgrade discourse to a fixed version for your release line: 2026.1.2, 2026.2.1 or 2026.3.0.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-33408 being exploited?

There is no known exploitation of CVE-2026-33408 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-33408, GHSA-wf9r-386h-g29c.

Is CVE-2026-33408 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free