CVE-2026-33409 Parse Server: Auth provider validation bypass on login via partial authData
Attackers can bypass authentication and take over accounts linked to third-party providers if expired auth data tokens are allowed.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-33409?
CVE-2026-33409 is a high-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 24 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.52 and 9.6.0-alpha.41, an authentication bypass vulnerability allows an attacker to log in as any user who has linked a third-party authentication provider, without knowing the user's credentials. The attacker only needs to know the user's provider ID to gain full access to their account, including a valid session token. This affects Parse Server deployments where the server option allowExpiredAuthDataToken is set to true. The default value is false. This issue has been patched in versions 8.6.52 and 9.6.0-alpha.41.
Weakness: CWE-287
Which versions are affected by CVE-2026-33409?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.52 |
parse-server npm | All versions | 8.6.52 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.41 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.41 |
parse Bitnami | All versions | 8.6.52, 9.6.0 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-33409?
Upgrade parse-server to a fixed version for your release line: 8.6.52 or 9.6.0-alpha.41.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-33409 being exploited?
There is no known exploitation of CVE-2026-33409 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-33409, GHSA-pfj7-wv7c-22pr.