{"answers":{"affected":"5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-33409 in the wild and no public exploit code.","fix":"Upgrade parse-server to a fixed version for your release line: 8.6.52 or 9.6.0-alpha.41.","what":"CVE-2026-33409 is a high-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 24 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-33409 and fix it if it is affected.\n\nWhat it is: CVE-2026-33409 is a high-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 24 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-33409 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- parse-server (npm): affected all versions; fixed in 8.6.52\n- parse-server (npm): affected all versions; fixed in 8.6.52\n- parse-server (npm): affected from 9.0.0; fixed in 9.6.0-alpha.41\n- parse-server (npm): affected from 9.0.0; fixed in 9.6.0-alpha.41\n- parse (Bitnami): affected all versions; fixed in 8.6.52, 9.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33409/ (Markdown: https://insights.sbomify.com/CVE-2026-33409/index.md)","id":"CVE-2026-33409","markdown":"https://insights.sbomify.com/CVE-2026-33409/index.md","name":"CVE-2026-33409","record":{"aliases":["BIT-parse-2026-33409","GHSA-pfj7-wv7c-22pr"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Parse Server backend","requires_auth":"high_privilege","summary":"Attackers can bypass authentication and take over accounts linked to third-party providers if expired auth data tokens are allowed.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"parse-server","vendor":"parseplatform"}],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.52 and 9.6.0-alpha.41, an authentication bypass vulnerability allows an attacker to log in as any user who has linked a third-party authentication provider, without knowing the user's credentials. The attacker only needs to know the user's provider ID to gain full access to their account, including a valid session token. This affects Parse Server deployments where the server option allowExpiredAuthDataToken is set to true. The default value is false. This issue has been patched in versions 8.6.52 and 9.6.0-alpha.41.","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Parse Server: Auth provider validation bypass on login via partial authData","id":"CVE-2026-33409","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"parseplatform:parse-server","products":["parseplatform:parse-server"],"type":"auth_bypass","year":"2026"},"n_packages":5,"n_references":5,"next":{"headline":"Discourse hardens chat DM channel creation and expansion","id":"CVE-2026-33410"},"packages":[{"ecosystem":"Bitnami","fixed":["8.6.52","9.6.0"],"introduced":["0","9.0.0"],"last_affected":[],"package":"parse","purl":"pkg:bitnami/parse","source":"BIT-parse-2026-33409"},{"ecosystem":"npm","fixed":["8.6.52"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-pfj7-wv7c-22pr"},{"ecosystem":"npm","fixed":["8.6.52"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-pfj7-wv7c-22pr"},{"ecosystem":"npm","fixed":["9.6.0-alpha.41"],"introduced":["9.0.0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-pfj7-wv7c-22pr"},{"ecosystem":"npm","fixed":["9.6.0-alpha.41"],"introduced":["9.0.0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-pfj7-wv7c-22pr"}],"prev":{"headline":"Discourse has Improper Authorization in \"Post Edits\" Report For Moderators","id":"CVE-2026-33408"},"products":["parse-server"],"published":"2026-03-24","related":[{"cvss_score":10,"headline":"Parse Server role escalation and CLP bypass via direct `_Join` table write","id":"CVE-2026-30966","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":10,"headline":"Parse Server literalizeRegexPart SQL Injection","id":"CVE-2024-27298","kev_date_added":null,"published":"2024-03-01"},{"cvss_score":10,"headline":"Command Injection in Parse server","id":"CVE-2022-24760","kev_date_added":null,"published":"2022-03-11"},{"cvss_score":9.9,"headline":"Parse Server session token exfiltration via `redirectClassNameForKey` query parameter","id":"CVE-2026-30965","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":9.8,"headline":"Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution","id":"CVE-2023-36475","kev_date_added":null,"published":"2023-06-28"},{"cvss_score":9.8,"headline":"Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser","id":"CVE-2022-39396","kev_date_added":null,"published":"2022-11-10"},{"cvss_score":9.3,"headline":"Parse Server: Account takeover via operator injection in authentication data identifier","id":"CVE-2026-32248","kev_date_added":null,"published":"2026-03-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-25","vendors":["parse-community"]},"summary":"Attackers can bypass authentication and take over accounts linked to third-party providers if expired auth data tokens are allowed.","url":"https://insights.sbomify.com/CVE-2026-33409/"}