# CVE-2026-33412: Vim affected by Command injection via newline in glob()

> Attackers can execute arbitrary shell commands via newline injection in Vim's glob() function, requiring specific shell settings.

- **Severity:** Medium 5.6 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Mar 2026
- **Updated:** 1 Sep 2026
- **Also known as:** ALPINE-CVE-2026-33412, AZL-80532, BELL-CVE-2026-33412, CLSA-2026-1777306218, CLSA-2026-1777385906, CLSA-2026-1777386117, CLSA-2026-1777446368, CLSA-2026-1777565595, CLSA-2026-1777661044, DEBIAN-CVE-2026-33412, ECHO-fa6f-2167-bb0a, GHSA-w5jw-f54h-x46c, MGASA-2026-0062, OESA-2026-1781, RHSA-2026:6725, ROOT-OS-DEBIAN-11-CVE-2026-33412, ROOT-OS-DEBIAN-12-CVE-2026-33412, UBUNTU-CVE-2026-33412

## What is CVE-2026-33412?

CVE-2026-33412 is a medium-severity command injection vulnerability in Vim Vim, published on 24 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Vim is an open source, command line text editor. Prior to version 9.2.0202, a command injection vulnerability exists in Vim's glob() function on Unix-like systems. By including a newline character (\n) in a pattern passed to glob(), an attacker may be able to execute arbitrary shell commands. This vulnerability depends on the user's 'shell' setting. This issue has been patched in version 9.2.0202.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-33412?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vim` | Red Hat:rhel_els:6 | All versions | 2:7.4.629-5.el6_10.3 |
| `vim-X11` | Red Hat:rhel_els:6 | All versions | 2:7.4.629-5.el6_10.3 |
| `vim-common` | Red Hat:rhel_els:6 | All versions | 2:7.4.629-5.el6_10.3 |
| `vim-debuginfo` | Red Hat:rhel_els:6 | All versions | 2:7.4.629-5.el6_10.3 |
| `vim-enhanced` | Red Hat:rhel_els:6 | All versions | 2:7.4.629-5.el6_10.3 |
| `vim-filesystem` | Red Hat:rhel_els:6 | All versions | 2:7.4.629-5.el6_10.3 |
| `vim-minimal` | Red Hat:rhel_els:6 | All versions | 2:7.4.629-5.el6_10.3 |

Products: Vim Vim.

## How do I fix CVE-2026-33412?

Upgrade to a fixed version.

## Is CVE-2026-33412 being exploited?

There is no known exploitation of CVE-2026-33412 in the wild and no public exploit code.

## Other vulnerabilities in Vim Vim

- [CVE-2020-20703](https://insights.sbomify.com/CVE-2020-20703/): Memory corruption in n/a (critical 9.8)
- [CVE-2017-6349](https://insights.sbomify.com/CVE-2017-6349/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-6350](https://insights.sbomify.com/CVE-2017-6350/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-5953](https://insights.sbomify.com/CVE-2017-5953/): Integer overflow in n/a (critical 9.8)
- [CVE-2008-3075](https://insights.sbomify.com/CVE-2008-3075/): Command injection in n/a (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33412 and fix it if it is affected.

What it is: CVE-2026-33412 is a medium-severity command injection vulnerability in Vim Vim, published on 24 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-33412 in the wild and no public exploit code.

Affected product: Vim Vim. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33412/ (Markdown: https://insights.sbomify.com/CVE-2026-33412/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33412
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33412
- OSV: https://osv.dev/vulnerability/CVE-2026-33412

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33412/
Summaries are generated and may contain mistakes; the official description above is the record.
