CVE-2026-33413 etcd: Authorization bypasses in multiple APIs
Unauthorized users can bypass authentication to access cluster topology, disrupt operations, or delete historical data in etcd clusters with auth enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33413?
CVE-2026-33413 is a high-severity authentication bypass vulnerability in etcd-io etcd, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
etcd is a distributed key-value store for the data of a distributed system. Prior to versions 3.4.42, 3.5.28, and 3.6.9, unauthorized users may bypass authentication or authorization checks and call certain etcd functions in clusters that expose the gRPC API to untrusted or partially trusted clients. In unpatched etcd clusters with etcd auth enabled, unauthorized users are able to call MemberList and learn cluster topology, including member IDs and advertised endpoints; call Alarm, which can be abused for operational disruption or denial of service; use Lease APIs, interfering with TTL-based keys and lease ownership; and/or trigger compaction, permanently removing historical revisions and disrupting watch, audit, and recovery workflows. Kubernetes does not rely on etcd’s built-in authentication and authorization. Instead, the API server handles authentication and authorization itself, so typical Kubernetes deployments are not affected. Versions 3.4.42, 3.5.28, and 3.6.9 contain a patch. If upgrading is not immediately possible, reduce exposure by treating the affected RPCs as unauthenticated in practice. Restrict network access to etcd server ports so only trusted components can connect and/or require strong client identity at the transport layer, such as mTLS with tightly scoped client certificate distribution.
Weakness: CWE-862
Which versions are affected by CVE-2026-33413?
11 open source packages ship an affected version, including go.etcd.io/etcd/v3, etcd and go.etcd.io/etcd. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
go.etcd.io/etcd/v3 Go | All versions | 3.4.42, 3.5.28, 3.6.9 |
go.etcd.io/etcd/v3 Go | All versions | 3.4.42 |
go.etcd.io/etcd/v3 Go | All versions | 3.4.42 |
go.etcd.io/etcd/v3 Go | From 3.5.0-alpha.0 | 3.5.28 |
go.etcd.io/etcd/v3 Go | From 3.5.0-alpha.0 | 3.5.28 |
go.etcd.io/etcd/v3 Go | From 3.6.0-alpha.0 | 3.6.9 |
5 more packages
go.etcd.io/etcd/v3 Go | From 3.6.0-alpha.0 | 3.6.9 |
etcd Bitnami | All versions | 3.4.42, 3.5.28, 3.6.9 |
go.etcd.io/etcd Go | All versions | None |
go.etcd.io/etcd Go | All versions to 3.3.27 | None |
go.etcd.io/etcd Go | All versions to 3.3.27 | None |
Linux distribution packages (1)
flannel openSUSE:Tumbleweed | All versions | 0.28.4-1.1 |
Products include Etcd Etcd.
How do I fix CVE-2026-33413?
Upgrade go.etcd.io/etcd/v3 to a fixed version for your release line: 3.4.42, 3.5.28 or 3.6.9.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-33413 being exploited?
There is no known exploitation of CVE-2026-33413 in the wild and no public exploit code.
Other vulnerabilities in etcd-io etcd
- CVE-2021-28235 Etcd-io Improper Authentication vulnerability
- CVE-2022-34038 Denial of service in n/a
- CVE-2018-16886 go.etcd.io/etcd Authentication Bypass
- CVE-2026-59818 etcd: gRPC client listener does not enforce `--client-crl-file` certificate revocation
- CVE-2020-15106 Improper Input Validation in etcd
Sources
Also known as AZL-80957, BIT-etcd-2026-33413, DEBIAN-CVE-2026-33413, GHSA-q8m4-xhhv-38mg, GO-2026-4806, MINI-76vc-6gcc-vgv8 and 7 more.