# CVE-2026-33413: etcd: Authorization bypasses in multiple APIs

> Unauthorized users can bypass authentication to access cluster topology, disrupt operations, or delete historical data in etcd clusters with auth enabled.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 26 Mar 2026
- **Also known as:** AZL-80957, BIT-etcd-2026-33413, DEBIAN-CVE-2026-33413, GHSA-q8m4-xhhv-38mg, GO-2026-4806, MINI-76vc-6gcc-vgv8, MINI-9vhq-cvhr-3f9f, MINI-h4xw-975c-4mvx, MINI-hc3q-7qw6-whgx, MINI-vqm7-4wpc-r5vp, MINI-wx95-7wq7-86c3, UBUNTU-CVE-2026-33413, openSUSE-SU-2026:10562-1

## What is CVE-2026-33413?

CVE-2026-33413 is a high-severity authentication bypass vulnerability in etcd-io etcd, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

etcd is a distributed key-value store for the data of a distributed system. Prior to versions 3.4.42, 3.5.28, and 3.6.9, unauthorized users may bypass authentication or authorization checks and call certain etcd functions in clusters that expose the gRPC API to untrusted or partially trusted clients. In unpatched etcd clusters with etcd auth enabled, unauthorized users are able to call MemberList and learn cluster topology, including member IDs and advertised endpoints; call Alarm, which can be abused for operational disruption or denial of service; use Lease APIs, interfering with TTL-based keys and lease ownership; and/or trigger compaction, permanently removing historical revisions and disrupting watch, audit, and recovery workflows. Kubernetes does not rely on etcd’s built-in authentication and authorization. Instead, the API server handles authentication and authorization itself, so typical Kubernetes deployments are not affected. Versions 3.4.42, 3.5.28, and 3.6.9 contain a patch. If upgrading is not immediately possible, reduce exposure by treating the affected RPCs as unauthenticated in practice. Restrict network access to etcd server ports so only trusted components can connect and/or require strong client identity at the transport layer, such as mTLS with tightly scoped client certificate distribution.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-33413?

11 open source packages ship an affected version, including go.etcd.io/etcd/v3, etcd and go.etcd.io/etcd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `go.etcd.io/etcd/v3` | Go | All versions | 3.4.42, 3.5.28, 3.6.9 |
| `go.etcd.io/etcd/v3` | Go | All versions | 3.4.42 |
| `go.etcd.io/etcd/v3` | Go | All versions | 3.4.42 |
| `go.etcd.io/etcd/v3` | Go | From 3.5.0-alpha.0 | 3.5.28 |
| `go.etcd.io/etcd/v3` | Go | From 3.5.0-alpha.0 | 3.5.28 |
| `go.etcd.io/etcd/v3` | Go | From 3.6.0-alpha.0 | 3.6.9 |
| `go.etcd.io/etcd/v3` | Go | From 3.6.0-alpha.0 | 3.6.9 |
| `etcd` | Bitnami | All versions | 3.4.42, 3.5.28, 3.6.9 |
| `go.etcd.io/etcd` | Go | All versions | None |
| `go.etcd.io/etcd` | Go | All versions to 3.3.27 | None |
| `go.etcd.io/etcd` | Go | All versions to 3.3.27 | None |
| `flannel` | openSUSE:Tumbleweed | All versions | 0.28.4-1.1 |

Products: Etcd Etcd.

## How do I fix CVE-2026-33413?

Upgrade go.etcd.io/etcd/v3 to a fixed version for your release line: 3.4.42, 3.5.28 or 3.6.9.

## Is CVE-2026-33413 being exploited?

There is no known exploitation of CVE-2026-33413 in the wild and no public exploit code.

## Other vulnerabilities in etcd-io etcd

- [CVE-2021-28235](https://insights.sbomify.com/CVE-2021-28235/): Etcd-io Improper Authentication vulnerability (critical 9.8)
- [CVE-2022-34038](https://insights.sbomify.com/CVE-2022-34038/): Denial of service in n/a (high 7.5)
- [CVE-2018-16886](https://insights.sbomify.com/CVE-2018-16886/): go.etcd.io/etcd Authentication Bypass (medium 6.8)
- [CVE-2026-59818](https://insights.sbomify.com/CVE-2026-59818/): etcd: gRPC client listener does not enforce `--client-crl-file` certificate revocation (medium 6.5)
- [CVE-2020-15106](https://insights.sbomify.com/CVE-2020-15106/): Improper Input Validation in etcd (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33413 and fix it if it is affected.

What it is: CVE-2026-33413 is a high-severity authentication bypass vulnerability in etcd-io etcd, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33413 in the wild and no public exploit code.

Affected packages and fixed versions:
- go.etcd.io/etcd/v3 (Go): affected all versions; fixed in 3.4.42, 3.5.28, 3.6.9
- go.etcd.io/etcd/v3 (Go): affected all versions; fixed in 3.4.42
- go.etcd.io/etcd/v3 (Go): affected all versions; fixed in 3.4.42
- go.etcd.io/etcd/v3 (Go): affected from 3.5.0-alpha.0; fixed in 3.5.28
- go.etcd.io/etcd/v3 (Go): affected from 3.5.0-alpha.0; fixed in 3.5.28
- go.etcd.io/etcd/v3 (Go): affected from 3.6.0-alpha.0; fixed in 3.6.9
- go.etcd.io/etcd/v3 (Go): affected from 3.6.0-alpha.0; fixed in 3.6.9
- etcd (Bitnami): affected all versions; fixed in 3.4.42, 3.5.28, 3.6.9
- go.etcd.io/etcd (Go): affected all versions; no fix listed
- go.etcd.io/etcd (Go): affected all versions up to 3.3.27; no fix listed
- go.etcd.io/etcd (Go): affected all versions up to 3.3.27; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33413/ (Markdown: https://insights.sbomify.com/CVE-2026-33413/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33413
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33413
- OSV: https://osv.dev/vulnerability/CVE-2026-33413

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33413/
Summaries are generated and may contain mistakes; the official description above is the record.
