CVE-2026-33414 PowerShell Command Injection in Podman HyperV Machine
Attackers can execute arbitrary PowerShell commands with SYSTEM privileges by injecting code into VM image paths in Podman's HyperV backend on Windows.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33414?
CVE-2026-33414 is a medium-severity command injection vulnerability in containers podman, published on 14 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Podman is a tool for managing OCI containers and pods. Versions 4.8.0 through 5.8.1 contain a command injection vulnerability in the HyperV machine backend in pkg/machine/hyperv/stubber.go, where the VM image path is inserted into a PowerShell double-quoted string without sanitization, allowing $() subexpression injection. Because PowerShell evaluates subexpressions inside double-quoted strings before executing the outer command, an attacker who can control the VM image path through a crafted machine name or image directory can execute arbitrary PowerShell commands with the privileges of the Podman process. On typical Windows installations this means SYSTEM-level code execution, and only Windows is affected as the code is exclusive to the HyperV backend. This issue has been patched in version 5.8.2.
Which versions are affected by CVE-2026-33414?
9 open source packages ship an affected version, including github.com/containers/podman/v4, github.com/containers/podman and github.com/containers/podman/v2. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/containers/podman/v4 Go | From 4.8.0 | None |
github.com/containers/podman/v4 Go | From 4.8.0 to 4.9.5 | None |
github.com/containers/podman/v4 Go | From 4.8.0 to 4.9.5 | None |
github.com/containers/podman Go | All versions | None |
github.com/containers/podman/v2 Go | All versions | None |
github.com/containers/podman/v3 Go | All versions | None |
3 more packages
github.com/containers/podman/v5 Go | All versions | 5.8.2 |
github.com/containers/podman/v5 Go | All versions | 5.8.2 |
github.com/containers/podman/v5 Go | All versions | 5.8.2 |
Linux distribution packages (1)
podman openSUSE:Tumbleweed | All versions | 5.8.2-1.1 |
Products include Podman Project Podman.
How do I fix CVE-2026-33414?
Upgrade to a fixed version.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-33414 being exploited?
There is no known exploitation of CVE-2026-33414 in the wild and no public exploit code.
Other vulnerabilities in containers podman
- CVE-2026-57231 Podman: Malformed Image can trick podman run into leaking host environment variables into the container
- CVE-2022-2738 Use after free in podman
- CVE-2022-2989 Podman's incorrect handling of the supplementary groups may lead to data disclosure, modification
- CVE-2021-20188 Improper Authorization in github.com/containers/libpod
- CVE-2023-0778 Podman Time-of-check Time-of-use (TOCTOU) Race Condition
Sources
Also known as AZL-82985, DEBIAN-CVE-2026-33414, GHSA-hc8w-h2mf-hp59, GO-2026-5421, MINI-j94x-3vqf-vv92, UBUNTU-CVE-2026-33414 and 1 more.