# CVE-2026-33414: PowerShell Command Injection in Podman HyperV Machine

> Attackers can execute arbitrary PowerShell commands with SYSTEM privileges by injecting code into VM image paths in Podman's HyperV backend on Windows.

- **Severity:** Medium 4.0 (`CVSS:4.0/AV:L/AC:H/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** AZL-82985, DEBIAN-CVE-2026-33414, GHSA-hc8w-h2mf-hp59, GO-2026-5421, MINI-j94x-3vqf-vv92, UBUNTU-CVE-2026-33414, openSUSE-SU-2026:10706-1

## What is CVE-2026-33414?

CVE-2026-33414 is a medium-severity command injection vulnerability in containers podman, published on 14 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Podman is a tool for managing OCI containers and pods. Versions 4.8.0 through 5.8.1 contain a command injection vulnerability in the HyperV machine backend in pkg/machine/hyperv/stubber.go, where the VM image path is inserted into a PowerShell double-quoted string without sanitization, allowing $() subexpression injection. Because PowerShell evaluates subexpressions inside double-quoted strings before executing the outer command, an attacker who can control the VM image path through a crafted machine name or image directory can execute arbitrary PowerShell commands with the privileges of the Podman process. On typical Windows installations this means SYSTEM-level code execution, and only Windows is affected as the code is exclusive to the HyperV backend. This issue has been patched in version 5.8.2.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-33414?

9 open source packages ship an affected version, including github.com/containers/podman/v4, github.com/containers/podman and github.com/containers/podman/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containers/podman/v4` | Go | From 4.8.0 | None |
| `github.com/containers/podman/v4` | Go | From 4.8.0 to 4.9.5 | None |
| `github.com/containers/podman/v4` | Go | From 4.8.0 to 4.9.5 | None |
| `github.com/containers/podman` | Go | All versions | None |
| `github.com/containers/podman/v2` | Go | All versions | None |
| `github.com/containers/podman/v3` | Go | All versions | None |
| `github.com/containers/podman/v5` | Go | All versions | 5.8.2 |
| `github.com/containers/podman/v5` | Go | All versions | 5.8.2 |
| `github.com/containers/podman/v5` | Go | All versions | 5.8.2 |
| `podman` | openSUSE:Tumbleweed | All versions | 5.8.2-1.1 |

Products: Podman Project Podman.

## How do I fix CVE-2026-33414?

Upgrade to a fixed version.

## Is CVE-2026-33414 being exploited?

There is no known exploitation of CVE-2026-33414 in the wild and no public exploit code.

## Other vulnerabilities in containers podman

- [CVE-2026-57231](https://insights.sbomify.com/CVE-2026-57231/): Podman: Malformed Image can trick podman run into leaking host environment variables into the container (high 7.5)
- [CVE-2022-2738](https://insights.sbomify.com/CVE-2022-2738/): Use after free in podman (high 7.5)
- [CVE-2022-2989](https://insights.sbomify.com/CVE-2022-2989/): Podman's incorrect handling of the supplementary groups may lead to data disclosure, modification (high 7.1)
- [CVE-2021-20188](https://insights.sbomify.com/CVE-2021-20188/): Improper Authorization in github.com/containers/libpod (high 7.0)
- [CVE-2023-0778](https://insights.sbomify.com/CVE-2023-0778/): Podman Time-of-check Time-of-use (TOCTOU) Race Condition (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33414 and fix it if it is affected.

What it is: CVE-2026-33414 is a medium-severity command injection vulnerability in containers podman, published on 14 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33414 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containers/podman/v4 (Go): affected from 4.8.0; no fix listed
- github.com/containers/podman/v4 (Go): affected from 4.8.0 up to 4.9.5; no fix listed
- github.com/containers/podman/v4 (Go): affected from 4.8.0 up to 4.9.5; no fix listed
- github.com/containers/podman (Go): affected all versions; no fix listed
- github.com/containers/podman/v2 (Go): affected all versions; no fix listed
- github.com/containers/podman/v3 (Go): affected all versions; no fix listed
- github.com/containers/podman/v5 (Go): affected all versions; fixed in 5.8.2
- github.com/containers/podman/v5 (Go): affected all versions; fixed in 5.8.2
- github.com/containers/podman/v5 (Go): affected all versions; fixed in 5.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33414/ (Markdown: https://insights.sbomify.com/CVE-2026-33414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33414
- OSV: https://osv.dev/vulnerability/CVE-2026-33414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33414/
Summaries are generated and may contain mistakes; the official description above is the record.
