# CVE-2026-33418: @dicebear/converter ensureSize() Vulnerable to SVG Dimension Capping Bypass via XML Comment Injection

> Attackers can bypass SVG dimension limits to cause out-of-memory crashes in applications using the DiceBear avatar library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** GHSA-7j2x-32w6-p43p

## What is CVE-2026-33418?

CVE-2026-33418 is a high-severity denial of service vulnerability in dicebear, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DiceBear is an avatar library for designers and developers. Prior to version 9.4.2, the `ensureSize()` function in `@dicebear/converter` used a regex-based approach to rewrite SVG `width`/`height` attributes, capping them at 2048px to prevent denial of service. This size capping could be bypassed by crafting SVG input that causes the regex to match a non-functional occurrence of `<svg` before the actual SVG root element. When the SVG is subsequently rendered via `@resvg/resvg-js` on the Node.js code path, it renders at the attacker-specified dimensions, potentially causing out-of-memory crashes. In version 9.4.2, the regex-based approach has been replaced with XML-aware processing using `fast-xml-parser` to correctly identify and modify the SVG root element's attributes. Additionally, a `fitTo` constraint has been added to the `renderAsync` call as defense-in-depth, ensuring the rendered output is always bounded regardless of SVG content.

Weakness: CWE-185 (Incorrect Regular Expression)

## Which versions are affected by CVE-2026-33418?

2 open source packages ship an affected version, including @dicebear/converter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@dicebear/converter` | npm | All versions | 9.4.2 |
| `@dicebear/converter` | npm | All versions | 9.4.2 |

Products: Dicebear Dicebear.

## How do I fix CVE-2026-33418?

Upgrade @dicebear/converter to 9.4.2 or later.

## Is CVE-2026-33418 being exploited?

There is no known exploitation of CVE-2026-33418 in the wild and no public exploit code.

## Other vulnerabilities in dicebear

- [CVE-2026-29112](https://insights.sbomify.com/CVE-2026-29112/): @dicebear/converter vulnerable to ncontrolled memory allocation via crafted SVG dimensions (high 7.5)
- [CVE-2026-33311](https://insights.sbomify.com/CVE-2026-33311/): @dicebear/core and @dicebear/initials Vulnerable to SVG Injection via Unsanitized Options (medium 4.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33418 and fix it if it is affected.

What it is: CVE-2026-33418 is a high-severity denial of service vulnerability in dicebear, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33418 in the wild and no public exploit code.

Affected packages and fixed versions:
- @dicebear/converter (npm): affected all versions; fixed in 9.4.2
- @dicebear/converter (npm): affected all versions; fixed in 9.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33418/ (Markdown: https://insights.sbomify.com/CVE-2026-33418/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33418
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33418
- OSV: https://osv.dev/vulnerability/CVE-2026-33418

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33418/
Summaries are generated and may contain mistakes; the official description above is the record.
