CVE-2026-33427 Discourse Authorization Page Displays Unvalidated Redirect Domain

Low 2.7 Published Updated

An attacker can manipulate the authorization page to display a malicious domain, enabling social engineering attacks against Discourse users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33427?

CVE-2026-33427 is a low-severity vulnerability in Discourse Discourse, published on 20 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, an unauthenticated attacker can cause a legitimate Discourse authorization page to display an attacker-controlled domain, facilitating social engineering attacks against users. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.

Weakness: CWE-862

Which versions are affected by CVE-2026-33427?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiFrom 2026.1.02026.1.2, 2026.2.1, 2026.3.0

Products include Discourse Discourse.

How do I fix CVE-2026-33427?

Upgrade discourse to a fixed version for your release line: 2026.1.2, 2026.2.1 or 2026.3.0.

Is CVE-2026-33427 being exploited?

There is no known exploitation of CVE-2026-33427 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-33427, GHSA-9vhg-2mx3-mqfr.

Is CVE-2026-33427 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free