CVE-2026-33428 Discourse Allows Unauthorized Access to Deleted Posts Index via Group Membership

Medium 4.9 Published Updated

Non-staff users with elevated group membership can access deleted posts belonging to any user due to an overly broad authorization check.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33428?

CVE-2026-33428 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 20 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, a non-staff user with elevated group membership could access deleted posts belonging to any user due to an overly broad authorization check on the deleted posts index endpoint. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.

Weakness: CWE-863

Which versions are affected by CVE-2026-33428?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiFrom 2026.1.02026.1.2, 2026.2.1, 2026.3.0

Products include Discourse Discourse.

How do I fix CVE-2026-33428?

Upgrade discourse to a fixed version for your release line: 2026.1.2, 2026.2.1 or 2026.3.0.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-33428 being exploited?

There is no known exploitation of CVE-2026-33428 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-33428, GHSA-frcw-p4mc-x6mp.

Is CVE-2026-33428 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free