CVE-2026-33430 Briefcase: Windows MSI Installer Privilege Escalation via Insecure Directory Permissions
A low-privilege user can modify application binaries in per-machine Windows installs, leading to code execution with administrator privileges when the app is run.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-33430?
CVE-2026-33430 is a high-severity vulnerability in beeware briefcase, published on 26 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
Briefcase is a tool for converting a Python project into a standalone native application. Starting in version 0.3.0 and prior to version 0.3.26, if a developer uses Briefcase to produce an Windows MSI installer for a project, and that project is installed for All Users (i.e., per-machine scope), the installation process creates an directory that inherits all the permissions of the parent directory. Depending on the location chosen by the installing user, this may allow a low privilege but authenticated user to replace or modify the binaries installed by the application. If an administrator then runs the altered binary, the binary will run with elevated privileges. The problem is caused by the template used to generate the WXS file for Windows projects. It was fixed in the templates used in Briefcase 0.3.26, 0.4.0, and 0.4.1. Re-running `briefcase create` on your Briefcase project will result in the updated templates being used. As a workaround, the patch can be added to any existing Briefcase .wxs file generated by Briefcase 0.3.24 or later.
Weakness: CWE-732
Which versions are affected by CVE-2026-33430?
3 open source packages ship an affected version, including briefcase. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
briefcase PyPI | From 0.3.0 | 0.3.26 |
briefcase PyPI | From 0.3.0 | 0.3.26 |
briefcase PyPI | From 0.3.0 | 0.3.26 |
Products include Beeware Briefcase.
How do I fix CVE-2026-33430?
Upgrade briefcase to 0.3.26 or later.
Is CVE-2026-33430 being exploited?
There is no known exploitation of CVE-2026-33430 in the wild and no public exploit code.
Sources
Also known as GHSA-r3r2-35v9-v238, PYSEC-2026-27.