# CVE-2026-33439: Pre-Authentication Remote Code Execution via `jato.clientSession` Deserialization in OpenAM

> Unauthenticated attackers can execute arbitrary code on OpenAM servers by sending malicious serialized Java objects via the jato.clientSession parameter.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-2cqq-rpvq-g5qj

## What is CVE-2026-33439?

CVE-2026-33439 is a critical unsafe deserialization vulnerability in OpenIdentityPlatform OpenAM, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Open Access Management (OpenAM) is an access management solution. Prior to 16.0.6, OpenIdentityPlatform OpenAM is vulnerable to pre-authentication Remote Code Execution (RCE) via unsafe Java deserialization of the jato.clientSession HTTP parameter. This bypasses the WhitelistObjectInputStream mitigation that was applied to the jato.pageSession parameter after CVE-2021-35464. An unauthenticated attacker can achieve arbitrary command execution on the server by sending a crafted serialized Java object as the jato.clientSession GET/POST parameter to any JATO ViewBean endpoint whose JSP contains <jato:form> tags (e.g., the Password Reset pages). This vulnerability is fixed in 16.0.6.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-33439?

2 open source packages ship an affected version, including org.openidentityplatform.openam:openam. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openidentityplatform.openam:openam` | Maven | All versions | 16.0.6 |
| `org.openidentityplatform.openam:openam` | Maven | All versions | 16.0.6 |

Products: Openidentityplatform Openam.

## How do I fix CVE-2026-33439?

Upgrade org.openidentityplatform.openam:openam to 16.0.6 or later.

## Is CVE-2026-33439 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33439 exists.

Public exploit code:

- First publicly shared exploit implementation for CVE-2026-33439 (OpenAM pre-auth RCE via jato.clientSession deserialization). (github_poc): https://github.com/TheMalwareGuardian/CVE-2026-33439
- Python PoC for CVE-2026-33439, an OpenAM pre-authentication RCE via jato.clientSession deserialization (github_poc): https://github.com/infernosalex/CVE-2026-33439-Python-PoC
- CVE-2026-33439 (github_poc): https://github.com/Ibonok/CVE-2026-33439-PoC
- Vulnerable endpoint description for CVE-2026-33439 in OpenAM (github_poc): https://github.com/shreyas-malhotra/CVE-2026-33439-OpenAM
- CVE-2026-33439 OpenAM pre-auth RCE PoC (github_poc): https://github.com/JonasChen0103/CVE-2026-33439-PoC
- Proof of concept for CVE-2026-33439, an unauthenticated RCE in OpenAM via Java deserialization (github_poc): https://github.com/rh33t/CVE-2026-33439-Poc

## Other vulnerabilities in OpenIdentityPlatform OpenAM

- [CVE-2023-37471](https://insights.sbomify.com/CVE-2023-37471/): User impersonation using SAMLv1.x SSO in Open Access Management (critical 9.1)
- [CVE-2022-34298](https://insights.sbomify.com/CVE-2022-34298/): NT auth module vulnerability in OpenAM (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33439 and fix it if it is affected.

What it is: CVE-2026-33439 is a critical unsafe deserialization vulnerability in OpenIdentityPlatform OpenAM, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33439 exists.

Affected packages and fixed versions:
- org.openidentityplatform.openam:openam (Maven): affected all versions; fixed in 16.0.6
- org.openidentityplatform.openam:openam (Maven): affected all versions; fixed in 16.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33439/ (Markdown: https://insights.sbomify.com/CVE-2026-33439/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33439
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33439
- OSV: https://osv.dev/vulnerability/CVE-2026-33439

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33439/
Summaries are generated and may contain mistakes; the official description above is the record.
