# CVE-2026-33453: Apache camel-coap allows header injection that can lead to remote code execution

> Unauthenticated attackers can inject headers via CoAP query parameters to execute arbitrary OS commands when routes use sensitive producers like camel-exec.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-695c-x5gc-94gj

## What is CVE-2026-33453?

CVE-2026-33453 is a critical code injection vulnerability in Apache Camel, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Apache Camel Camel-Coap component.

Apache Camel's camel-coap component is vulnerable to Camel message header injection, leading to remote code execution when routes forward CoAP requests to header-sensitive producers (e.g. camel-exec)

The camel-coap component maps incoming CoAP request URI query parameters directly into Camel Exchange In message headers without applying any HeaderFilterStrategy.    
Specifically, CamelCoapResource.handleRequest() iterates over OptionSet.getUriQuery() and calls camelExchange.getIn().setHeader(...) for every query parameter. CoAPEndpoint extends DefaultEndpoint rather than DefaultHeaderFilterStrategyEndpoint, and CoAPComponent does not implement HeaderFilterStrategyComponent; the component contains no references to HeaderFilterStrategy at all.

As a result, an unauthenticated attacker who can send a single CoAP UDP packet to a Camel route consuming from coap:// can inject arbitrary Camel internal headers (those prefixed with Camel*) into the Exchange. When the route delivers the message to a header-sensitive producer such as camel-exec, camel-sql, camel-bean, camel-file, or template components (camel-freemarker, camel-velocity), the injected headers can alter the producer's behavior. In the case of camel-exec, the CamelExecCommandExecutable and CamelExecCommandArgs headers override the executable and arguments configured on the endpoint, resulting in arbitrary OS command execution under the privileges of the Camel process.

The producer's output is written back to the Exchange body and returned in the CoAP response payload by CamelCoapResource, giving the attacker an interactive RCE channel without any need for out-of-band exfiltration.
                                                                                                                                                                         
Exploitation prerequisites are minimal: a single unauthenticated UDP datagram to the CoAP port (default 5683). CoAP (RFC 7252) has no built-in authentication, and DTLS is optional and disabled by default. Because the protocol is UDP-based, HTTP-layer WAF/IDS controls do not apply.
This issue affects Apache Camel: from 4.14.0 through 4.14.5, from 4.18.0 before 4.18.1, 4.19.0.

Users are recommended to upgrade to version 4.18.1 or 4.19.0, fixing the issue.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes)

## Which versions are affected by CVE-2026-33453?

4 open source packages ship an affected version, including org.apache.camel:camel-coap. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-coap` | Maven | From 4.14.0 | 4.14.6 |
| `org.apache.camel:camel-coap` | Maven | From 4.14.0 | 4.14.6 |
| `org.apache.camel:camel-coap` | Maven | From 4.18.0 | 4.18.1 |
| `org.apache.camel:camel-coap` | Maven | From 4.18.0 | 4.18.1 |

Products: Apache Camel.

## How do I fix CVE-2026-33453?

Upgrade org.apache.camel:camel-coap to a fixed version for your release line: 4.14.6 or 4.18.1.

## Is CVE-2026-33453 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33453 exists.

Public exploit code:

- Apache Camel 4.18.0 — CVE Security Assessment: 3 critical vulnerabilities with working PoC exploits (CVE-2026-33453, CVE-2026-40473, CVE-2026-40858) (github_poc): https://github.com/dinosn/CVE-2026-33453
- Reproducer for CVE-2026-33453: Apache Camel camel-coap header injection to RCE via camel-exec (github_poc): https://github.com/oscerd/CVE-2026-33453
- Apache Camel camel-coap - Remote Code Execution (nuclei)

## Other vulnerabilities in Apache Camel

- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)
- [CVE-2026-78329](https://insights.sbomify.com/CVE-2026-78329/): Apache Camel-Undertow: the endpoint discarded the undertow-specific header filter strategy in favour of the base HTTP one, so the undertow filtering never ran on endpoint-configured routes (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33453 and fix it if it is affected.

What it is: CVE-2026-33453 is a critical code injection vulnerability in Apache Camel, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33453 exists.

Affected packages and fixed versions:
- org.apache.camel:camel-coap (Maven): affected from 4.14.0; fixed in 4.14.6
- org.apache.camel:camel-coap (Maven): affected from 4.14.0; fixed in 4.14.6
- org.apache.camel:camel-coap (Maven): affected from 4.18.0; fixed in 4.18.1
- org.apache.camel:camel-coap (Maven): affected from 4.18.0; fixed in 4.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33453/ (Markdown: https://insights.sbomify.com/CVE-2026-33453/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33453
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33453
- OSV: https://osv.dev/vulnerability/CVE-2026-33453

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33453/
Summaries are generated and may contain mistakes; the official description above is the record.
