CVE-2026-33454 Apache Camel's Camel-Mail component is vulnerable to Camel message header injection
Attackers can inject Camel headers via email to trigger remote code execution in downstream components like camel-exec or camel-sql.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33454?
CVE-2026-33454 is a critical code injection vulnerability in Apache Camel, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Camel-Mail component is vulnerable to Camel message header injection. The custom header filter strategy used by the component (MailHeaderFilterStrategy) only filters the 'out' direction via setOutFilterStartsWith, while it does not configure the 'in' direction via setInFilterStartsWith. As a result, when a Camel application consumes mail through camel-mail (for example via from(\"imap://...\") or from(\"pop3://...\")) the inbound filter check is skipped and Camel-prefixed MIME headers are mapped unfiltered into the Exchange. An attacker who can deliver an email to a mailbox monitored by such a consumer can inject Camel-specific headers that, for some Camel components downstream of the mail consumer (such as camel-bean, camel-exec, or camel-sql), can alter the behaviour of the route. This is the same pattern that was previously addressed in camel-undertow (CVE-2025-30177) and the broader incoming-header filter (CVE-2025-27636 and CVE-2025-29891).
This issue affects Apache Camel: from 3.0.0 before 4.14.6, from 4.15.0 before 4.18.1.
Users are recommended to upgrade to version 4.19.0, which fixes the issue. If users are on the 4.18.x LTS releases stream, then they are suggested to upgrade to 4.18.1. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.6.
Which versions are affected by CVE-2026-33454?
4 open source packages ship an affected version, including org.apache.camel:camel-mail. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.camel:camel-mail Maven | From 3.0.0 | 4.14.6 |
org.apache.camel:camel-mail Maven | From 3.0.0 | 4.14.6 |
org.apache.camel:camel-mail Maven | From 4.15.0 | 4.18.1 |
org.apache.camel:camel-mail Maven | From 4.15.0 | 4.18.1 |
Products include Apache Camel.
How do I fix CVE-2026-33454?
Upgrade org.apache.camel:camel-mail to a fixed version for your release line: 4.14.6 or 4.18.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-33454 being exploited?
There is no known exploitation of CVE-2026-33454 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Camel
- CVE-2026-33453 Apache camel-coap allows header injection that can lead to remote code execution
- CVE-2026-40453 Apache Camel has an incomplete fix for CVE-2025-27636
- CVE-2026-80351 Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod
- CVE-2026-80352 Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects
- CVE-2026-71300 Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection
Sources
Also known as GHSA-2vqf-x7g4-7c2g.