# CVE-2026-33454: Apache Camel's Camel-Mail component is vulnerable to Camel message header injection

> Attackers can inject Camel headers via email to trigger remote code execution in downstream components like camel-exec or camel-sql.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-2vqf-x7g4-7c2g

## What is CVE-2026-33454?

CVE-2026-33454 is a critical code injection vulnerability in Apache Camel, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Camel-Mail component is vulnerable to Camel message header injection. The custom header filter strategy used by the component (MailHeaderFilterStrategy) only filters the 'out' direction via setOutFilterStartsWith, while it does not configure the 'in' direction via setInFilterStartsWith. As a result, when a Camel application consumes mail through camel-mail (for example via from(\"imap://...\") or from(\"pop3://...\")) the inbound filter check is skipped and Camel-prefixed MIME headers are mapped unfiltered into the Exchange. An attacker who can deliver an email to a mailbox monitored by such a consumer can inject Camel-specific headers that, for some Camel components downstream of the mail consumer (such as camel-bean, camel-exec, or camel-sql), can alter the behaviour of the route. This is the same pattern that was previously addressed in camel-undertow (CVE-2025-30177) and the broader incoming-header filter (CVE-2025-27636 and CVE-2025-29891).

This issue affects Apache Camel: from 3.0.0 before 4.14.6, from 4.15.0 before 4.18.1.

Users are recommended to upgrade to version 4.19.0, which fixes the issue. If users are on the 4.18.x LTS releases stream, then they are suggested to upgrade to 4.18.1. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.6.

Weakness: CWE-1173 (Improper Use of Validation Framework), CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-33454?

4 open source packages ship an affected version, including org.apache.camel:camel-mail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-mail` | Maven | From 3.0.0 | 4.14.6 |
| `org.apache.camel:camel-mail` | Maven | From 3.0.0 | 4.14.6 |
| `org.apache.camel:camel-mail` | Maven | From 4.15.0 | 4.18.1 |
| `org.apache.camel:camel-mail` | Maven | From 4.15.0 | 4.18.1 |

Products: Apache Camel.

## How do I fix CVE-2026-33454?

Upgrade org.apache.camel:camel-mail to a fixed version for your release line: 4.14.6 or 4.18.1.

## Is CVE-2026-33454 being exploited?

There is no known exploitation of CVE-2026-33454 in the wild and no public exploit code.

Public exploit code:

- Reproducer for CVE-2026-33454: Apache Camel camel-mail header injection to RCE via camel-exec (github_poc): https://github.com/oscerd/CVE-2026-33454

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33454 and fix it if it is affected.

What it is: CVE-2026-33454 is a critical code injection vulnerability in Apache Camel, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33454 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-mail (Maven): affected from 3.0.0; fixed in 4.14.6
- org.apache.camel:camel-mail (Maven): affected from 3.0.0; fixed in 4.14.6
- org.apache.camel:camel-mail (Maven): affected from 4.15.0; fixed in 4.18.1
- org.apache.camel:camel-mail (Maven): affected from 4.15.0; fixed in 4.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33454/ (Markdown: https://insights.sbomify.com/CVE-2026-33454/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33454
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33454
- OSV: https://osv.dev/vulnerability/CVE-2026-33454

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33454/
Summaries are generated and may contain mistakes; the official description above is the record.
