# CVE-2026-33467: Improper Verification of Cryptographic Signature in Elastic Package Registry Leading to Package Integrity Bypass

> Attackers can bypass integrity checks to install tampered packages in Elastic Package Registry, potentially leading to code execution.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Apr 2026
- **Updated:** 29 Apr 2026
- **Also known as:** GHSA-r727-5pf6-47r2, GO-2026-5611

## What is CVE-2026-33467?

CVE-2026-33467 is a medium-severity vulnerability in Elastic Package Registry, published on 28 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Verification of Cryptographic Signature (CWE-347) in Elastic Package Registry could allow an attacker positioned to intercept network traffic, or to otherwise influence the contents served to a self-hosted registry, to substitute a tampered package without the integrity check failing closed.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-33467?

3 open source packages ship an affected version, including github.com/elastic/package-registry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/elastic/package-registry` | Go | All versions | 1.38.0 |
| `github.com/elastic/package-registry` | Go | All versions | 1.38.0 |
| `github.com/elastic/package-registry` | Go | All versions | 1.38.0 |

Products: Elastic Elastic Package Registry.

## How do I fix CVE-2026-33467?

Upgrade github.com/elastic/package-registry to 1.38.0 or later.

## Is CVE-2026-33467 being exploited?

There is no known exploitation of CVE-2026-33467 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33467 and fix it if it is affected.

What it is: CVE-2026-33467 is a medium-severity vulnerability in Elastic Package Registry, published on 28 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33467 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/elastic/package-registry (Go): affected all versions; fixed in 1.38.0
- github.com/elastic/package-registry (Go): affected all versions; fixed in 1.38.0
- github.com/elastic/package-registry (Go): affected all versions; fixed in 1.38.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33467/ (Markdown: https://insights.sbomify.com/CVE-2026-33467/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33467
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33467
- OSV: https://osv.dev/vulnerability/CVE-2026-33467

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33467/
Summaries are generated and may contain mistakes; the official description above is the record.
