# CVE-2026-33495: Ory Oathkeeper has an authentication bypass by usage of untrusted header

> Attackers can bypass authentication rules by spoofing the X-Forwarded-Proto header when specific HTTP/HTTPS rule distinctions exist.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 26 Mar 2026
- **Also known as:** GHSA-vhr5-ggp3-qq85, GO-2026-4810

## What is CVE-2026-33495?

CVE-2026-33495 is a medium-severity authentication bypass vulnerability in ory oathkeeper, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ORY Oathkeeper is an Identity & Access Proxy (IAP) and Access Control Decision API that authorizes HTTP requests based on sets of Access Rules. Ory Oathkeeper is often deployed behind other components like CDNs, WAFs, or reverse proxies. Depending on the setup, another component might forward the request to the Oathkeeper proxy with a different protocol (http vs. https) than the original request. In order to properly match the request against the configured rules, Oathkeeper considers the `X-Forwarded-Proto`  header when evaluating rules. The configuration option `serve.proxy.trust_forwarded_headers` (defaults to false) governs whether this and other `X-Forwarded-*` headers should be trusted. Prior to version 26.2.0, Oathkeeper did not properly respect this configuration, and would always consider the `X-Forwarded-Proto`  header. In order for an attacker to abuse this, an installation of Ory Oathkeeper needs to have distinct rules for HTTP and HTTPS requests. Also, the attacker needs to be able to trigger one but not the other rule. In this scenario, the attacker can send the same request but with the `X-Forwarded-Proto`  header in order to trigger the other rule. We do not expect many configurations to meet these preconditions. Version 26.2.0 contains a patch. Ory Oathkeeper will correctly respect the `serve.proxy.trust_forwarded_headers` configuration going forward, thereby eliminating the attack scenario. We recommend upgrading to a fixed version even if the preconditions are not met. As an additional mitigation, it is generally recommended to drop any unexpected headers as early as possible when a request is handled, e.g. in the WAF.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-33495?

3 open source packages ship an affected version, including github.com/ory/oathkeeper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ory/oathkeeper` | Go | All versions | 0.40.10-0.20260320084810-e9acca14a04d |
| `github.com/ory/oathkeeper` | Go | All versions | 0.40.10-0.20260320084810-e9acca14a04d |
| `github.com/ory/oathkeeper` | Go | All versions | 0.40.10-0.20260320084810-e9acca14a04d |

Products: Ory Oathkeeper.

## How do I fix CVE-2026-33495?

Upgrade github.com/ory/oathkeeper to 0.40.10-0.20260320084810-e9acca14a04d or later.

## Is CVE-2026-33495 being exploited?

There is no known exploitation of CVE-2026-33495 in the wild and no public exploit code.

## Other vulnerabilities in ory oathkeeper

- [CVE-2026-33494](https://insights.sbomify.com/CVE-2026-33494/): Ory Oathkeeper has a path traversal authorization bypass (critical 10.0)
- [CVE-2026-33496](https://insights.sbomify.com/CVE-2026-33496/): Ory Oathkeeper has an authentication bypass by cache key confusion (high 8.1)
- [CVE-2021-32701](https://insights.sbomify.com/CVE-2021-32701/): Possible bypass of token claim validation when OAuth2 Introspection caching is enabled (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33495 and fix it if it is affected.

What it is: CVE-2026-33495 is a medium-severity authentication bypass vulnerability in ory oathkeeper, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33495 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ory/oathkeeper (Go): affected all versions; fixed in 0.40.10-0.20260320084810-e9acca14a04d
- github.com/ory/oathkeeper (Go): affected all versions; fixed in 0.40.10-0.20260320084810-e9acca14a04d
- github.com/ory/oathkeeper (Go): affected all versions; fixed in 0.40.10-0.20260320084810-e9acca14a04d

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33495/ (Markdown: https://insights.sbomify.com/CVE-2026-33495/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33495
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33495
- OSV: https://osv.dev/vulnerability/CVE-2026-33495

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33495/
Summaries are generated and may contain mistakes; the official description above is the record.
