CVE-2026-33496 Ory Oathkeeper has an authentication bypass by cache key confusion
Attackers can bypass authentication in Ory Oathkeeper by exploiting cache key confusion when multiple introspection servers are configured with caching enabled.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33496?
CVE-2026-33496 is a high-severity authentication bypass vulnerability in ory oathkeeper, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
ORY Oathkeeper is an Identity & Access Proxy (IAP) and Access Control Decision API that authorizes HTTP requests based on sets of Access Rules. Versions prior to 26.2.0 are vulnerable to authentication bypass due to cache key confusion. The `oauth2_introspection` authenticator cache does not distinguish tokens that were validated with different introspection URLs. An attacker can therefore legitimately use a token to prime the cache, and subsequently use the same token for rules that use a different introspection server. Ory Oathkeeper has to be configured with multiple `oauth2_introspection` authenticator servers, each accepting different tokens. The authenticators also must be configured to use caching. An attacker has to have a way to gain a valid token for one of the configured introspection servers. Starting in version 26.2.0, Ory Oathkeeper includes the introspection server URL in the cache key, preventing confusion of tokens. Update to the patched version of Ory Oathkeeper. If that is not immediately possible, disable caching for `oauth2_introspection` authenticators.
Which versions are affected by CVE-2026-33496?
3 open source packages ship an affected version, including github.com/ory/oathkeeper. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/ory/oathkeeper Go | All versions | 0.40.10-0.20260320084801-198a2bc82a99 |
github.com/ory/oathkeeper Go | All versions | 0.40.10-0.20260320084801-198a2bc82a99 |
github.com/ory/oathkeeper Go | All versions | 0.40.10-0.20260320084801-198a2bc82a99 |
Products include Ory Oathkeeper.
How do I fix CVE-2026-33496?
Upgrade github.com/ory/oathkeeper to 0.40.10-0.20260320084801-198a2bc82a99 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-33496 being exploited?
There is no known exploitation of CVE-2026-33496 in the wild and no public exploit code.
Other vulnerabilities in ory oathkeeper
Sources
Also known as GHSA-4mq7-pvjg-xp2r, GO-2026-4799.