# CVE-2026-33496: Ory Oathkeeper has an authentication bypass by cache key confusion

> Attackers can bypass authentication in Ory Oathkeeper by exploiting cache key confusion when multiple introspection servers are configured with caching enabled.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 30 Mar 2026
- **Also known as:** GHSA-4mq7-pvjg-xp2r, GO-2026-4799

## What is CVE-2026-33496?

CVE-2026-33496 is a high-severity authentication bypass vulnerability in ory oathkeeper, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ORY Oathkeeper is an Identity & Access Proxy (IAP) and Access Control Decision API that authorizes HTTP requests based on sets of Access Rules. Versions prior to 26.2.0 are  vulnerable to authentication bypass due to cache key confusion. The `oauth2_introspection` authenticator cache does not distinguish tokens that were validated with different introspection URLs. An attacker can therefore legitimately use a token to prime the cache, and subsequently use the same token for rules that use a different introspection server. Ory Oathkeeper has to be configured with multiple `oauth2_introspection` authenticator servers, each accepting different tokens. The authenticators also must be configured to use caching. An attacker has to have a way to gain a valid token for one of the configured introspection servers. Starting in version 26.2.0, Ory Oathkeeper includes the introspection server URL in the cache key, preventing confusion of tokens. Update to the patched version of Ory Oathkeeper. If that is not immediately possible, disable caching for `oauth2_introspection` authenticators.

Weakness: CWE-305 (Authentication Bypass by Primary Weakness), CWE-1289 (Improper Validation of Unsafe Equivalence in Input)

## Which versions are affected by CVE-2026-33496?

3 open source packages ship an affected version, including github.com/ory/oathkeeper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ory/oathkeeper` | Go | All versions | 0.40.10-0.20260320084801-198a2bc82a99 |
| `github.com/ory/oathkeeper` | Go | All versions | 0.40.10-0.20260320084801-198a2bc82a99 |
| `github.com/ory/oathkeeper` | Go | All versions | 0.40.10-0.20260320084801-198a2bc82a99 |

Products: Ory Oathkeeper.

## How do I fix CVE-2026-33496?

Upgrade github.com/ory/oathkeeper to 0.40.10-0.20260320084801-198a2bc82a99 or later.

## Is CVE-2026-33496 being exploited?

There is no known exploitation of CVE-2026-33496 in the wild and no public exploit code.

## Other vulnerabilities in ory oathkeeper

- [CVE-2026-33494](https://insights.sbomify.com/CVE-2026-33494/): Ory Oathkeeper has a path traversal authorization bypass (critical 10.0)
- [CVE-2021-32701](https://insights.sbomify.com/CVE-2021-32701/): Possible bypass of token claim validation when OAuth2 Introspection caching is enabled (high 7.5)
- [CVE-2026-33495](https://insights.sbomify.com/CVE-2026-33495/): Ory Oathkeeper has an authentication bypass by usage of untrusted header (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33496 and fix it if it is affected.

What it is: CVE-2026-33496 is a high-severity authentication bypass vulnerability in ory oathkeeper, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33496 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ory/oathkeeper (Go): affected all versions; fixed in 0.40.10-0.20260320084801-198a2bc82a99
- github.com/ory/oathkeeper (Go): affected all versions; fixed in 0.40.10-0.20260320084801-198a2bc82a99
- github.com/ory/oathkeeper (Go): affected all versions; fixed in 0.40.10-0.20260320084801-198a2bc82a99

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33496/ (Markdown: https://insights.sbomify.com/CVE-2026-33496/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33496
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33496
- OSV: https://osv.dev/vulnerability/CVE-2026-33496

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33496/
Summaries are generated and may contain mistakes; the official description above is the record.
