CVE-2026-33508 Parse Server: LiveQuery subscription query depth bypass

High 8.2 Published Updated

Attackers can cause service disruption in Parse Server by sending deeply nested LiveQuery subscriptions that bypass complexity limits, leading to excessive CPU consumption.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33508?

CVE-2026-33508 is a high-severity denial of service vulnerability in Parseplatform Parse-Server, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.56 and 9.6.0-alpha.45, Parse Server's LiveQuery component does not enforce the requestComplexity.queryDepth configuration setting when processing WebSocket subscription requests. An attacker can send a subscription with deeply nested logical operators, causing excessive recursion and CPU consumption that degrades or disrupts service availability. This issue has been patched in versions 8.6.56 and 9.6.0-alpha.45.

Weakness: CWE-674

Which versions are affected by CVE-2026-33508?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.

PackageAffectedFixed in
parse-server npmAll versions8.6.56
parse-server npmAll versions8.6.56
parse-server npmFrom 9.0.09.6.0-alpha.45
parse-server npmFrom 9.0.09.6.0-alpha.45
parse BitnamiAll versions8.6.56, 9.6.0

Products include Parseplatform Parse-Server.

How do I fix CVE-2026-33508?

Upgrade parse-server to a fixed version for your release line: 8.6.56 or 9.6.0-alpha.45.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-33508 being exploited?

There is no known exploitation of CVE-2026-33508 in the wild and no public exploit code.

All Parseplatform Parse-Server vulnerabilities

Sources

Also known as BIT-parse-2026-33508, GHSA-6qh5-m6g3-xhq6.

Is CVE-2026-33508 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free