# CVE-2026-33509: pyload-ng: SETTINGS Permission Users Can Achieve Remote Code Execution via Unrestricted Reconnect Script Configuration

> Users with SETTINGS permission can achieve remote code execution by modifying the unrestricted reconnect script configuration in pyLoad.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Mar 2026
- **Updated:** 26 Mar 2026
- **Also known as:** GHSA-r7mc-x6x7-cqxx, PYSEC-2026-2996

## What is CVE-2026-33509?

CVE-2026-33509 is a high-severity command injection vulnerability in pyload, published on 24 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pyLoad is a free and open-source download manager written in Python. From version 0.4.0 to before version 0.5.0b3.dev97, the set_config_value() API endpoint allows users with the non-admin SETTINGS permission to modify any configuration option without restriction. The reconnect.script config option controls a file path that is passed directly to subprocess.run() in the thread manager's reconnect logic. A SETTINGS user can set this to any executable file on the system, achieving Remote Code Execution. The only validation in set_config_value() is a hardcoded check for general.storage_folder — all other security-critical settings including reconnect.script are writable without any allowlist or path restriction. This issue has been patched in version 0.5.0b3.dev97.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-33509?

3 open source packages ship an affected version, including pyload-ng. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyload-ng` | PyPI | From 0.4.0 to 0.5.0b3.dev96 | None |
| `pyload-ng` | PyPI | From 0.4.0 to 0.5.0b3.dev96 | None |
| `pyload-ng` | PyPI | From 0.4.0 to 0.5.0b3.dev96 | None |

Products: Pyload-Ng Project Pyload-Ng, Pyload Pyload.

## How do I fix CVE-2026-33509?

No fix has been published for CVE-2026-33509 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-33509 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33509 exists.

## Other vulnerabilities in pyload

- [CVE-2025-54802](https://insights.sbomify.com/CVE-2025-54802/): pyLoad CNL Blueprint is vulnerable to Path Traversal through `dlc_path` leading to Remote Code Execution (RCE) (critical 9.8)
- [CVE-2024-22416](https://insights.sbomify.com/CVE-2024-22416/): Cross-Site Request Forgery on any API call in pyLoad may lead to admin privilege escalation (critical 9.7)
- [CVE-2023-0488](https://insights.sbomify.com/CVE-2023-0488/): Cross-site Scripting (XSS) - Stored in pyload/pyload (critical 9.6)
- [CVE-2026-35459](https://insights.sbomify.com/CVE-2026-35459/): pyLoad has SSRF fix bypass via HTTP redirect (critical 9.3)
- [CVE-2026-35463](https://insights.sbomify.com/CVE-2026-35463/): pyLoad has Improper Neutralization of Special Elements used in an OS Command (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33509 and fix it if it is affected.

What it is: CVE-2026-33509 is a high-severity command injection vulnerability in pyload, published on 24 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33509 exists.

Affected packages and fixed versions:
- pyload-ng (PyPI): affected from 0.4.0 up to 0.5.0b3.dev96; no fix listed
- pyload-ng (PyPI): affected from 0.4.0 up to 0.5.0b3.dev96; no fix listed
- pyload-ng (PyPI): affected from 0.4.0 up to 0.5.0b3.dev96; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33509/ (Markdown: https://insights.sbomify.com/CVE-2026-33509/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33509
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33509
- OSV: https://osv.dev/vulnerability/CVE-2026-33509

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33509/
Summaries are generated and may contain mistakes; the official description above is the record.
