CVE-2026-33514 Discourse: Information Disclosure in Form Template API Due to Missing Authorization
Authenticated users can read unauthorized form template metadata if the feature is enabled, requiring an upgrade to fix.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33514?
CVE-2026-33514 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 19 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Discourse is an open-source discussion platform. In versions prior to 2026.1.4, 2026.3.1, 2026.4.1 and 2026.5.0-latest.1, an authenticated user on a Discourse instance with the form templates feature enabled can read the name and structured content of form templates that are intended exclusively for categories they are not authorized to access. Impact is limited to disclosure of site configuration metadata. This issue has been fixed in versions 2026.1.4, 2026.3.1, 2026.4.1 and 2026.5.0-latest.1.
Weakness: CWE-862
Which versions are affected by CVE-2026-33514?
1 open source package ship an affected version, including discourse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | All versions | 2026.1.4, 2026.3.1, 2026.4.1 |
Products include Discourse Discourse.
How do I fix CVE-2026-33514?
Upgrade discourse to a fixed version for your release line: 2026.1.4, 2026.3.1 or 2026.4.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-33514 being exploited?
There is no known exploitation of CVE-2026-33514 in the wild and no public exploit code.
Other vulnerabilities in Discourse Discourse
- CVE-2021-41163 RCE via malicious SNS subscription payload
- CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file
- CVE-2022-39356 Discourse user account takeover via email and invite link
- CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes
- CVE-2026-27934 Discourse leaks private topic title and post excerpt via user action API endpoint
Sources
Also known as BIT-discourse-2026-33514, GHSA-w6g7-p2p9-2m5h.