# CVE-2026-33514: Discourse: Information Disclosure in Form Template API Due to Missing Authorization

> Authenticated users can read unauthorized form template metadata if the feature is enabled, requiring an upgrade to fix.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2026
- **Updated:** 19 May 2026
- **Also known as:** BIT-discourse-2026-33514, GHSA-w6g7-p2p9-2m5h

## What is CVE-2026-33514?

CVE-2026-33514 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 19 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. In versions prior to 2026.1.4, 2026.3.1, 2026.4.1 and 2026.5.0-latest.1, an authenticated user on a Discourse instance with the form templates feature enabled can read the name and structured content of form templates that are intended exclusively for categories they are not authorized to access. Impact is limited to disclosure of site configuration metadata. This issue has been fixed in versions 2026.1.4, 2026.3.1, 2026.4.1 and 2026.5.0-latest.1.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-33514?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2026.1.4, 2026.3.1, 2026.4.1 |

Products: Discourse Discourse.

## How do I fix CVE-2026-33514?

Upgrade discourse to a fixed version for your release line: 2026.1.4, 2026.3.1 or 2026.4.1.

## Is CVE-2026-33514 being exploited?

There is no known exploitation of CVE-2026-33514 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33514 and fix it if it is affected.

What it is: CVE-2026-33514 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 19 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33514 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2026.1.4, 2026.3.1, 2026.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33514/ (Markdown: https://insights.sbomify.com/CVE-2026-33514/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33514
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33514
- OSV: https://osv.dev/vulnerability/CVE-2026-33514

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33514/
Summaries are generated and may contain mistakes; the official description above is the record.
