CVE-2026-33523 Apache HTTP Server: multiple modules: HTTP response splitting forwarding malicious status line
Attackers can perform HTTP response splitting via compromised backends, allowing header injection and cache poisoning in Apache HTTP Server.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33523?
CVE-2026-33523 is a medium-severity vulnerability in Apache Http Server, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
HTTP response splitting vulnerability in multiple Apache HTTP Server modules with untrusted or compromised backend servers.
This issue affects Apache HTTP Server: from through 2.4.66.
Users are recommended to upgrade to version 2.4.67, which fixes the issue.
Weakness: CWE-443
Which versions are affected by CVE-2026-33523?
1 open source package ship an affected version, including apache. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache Bitnami | From 2.4.0 | 2.4.67 |
Products include Apache Http Server.
How do I fix CVE-2026-33523?
Upgrade apache to 2.4.67 or later.
Is CVE-2026-33523 being exploited?
There is no known exploitation of CVE-2026-33523 in the wild and no public exploit code.
Other vulnerabilities in Apache Http Server
Sources
Also known as ALPINE-CVE-2026-33523, AZL-86022, BELL-CVE-2026-33523, BIT-apache-2026-33523, DEBIAN-CVE-2026-33523, GHSA-fc75-39v4-qm5p and 2 more.